Danke Danke:  0
Gefällt mir Gefällt mir:  0
Dislikes Dislikes:  0
Ergebnis 1 bis 13 von 13

Thema: DOS-Ordner verschieben in einer Batch Datei funktioniert nicht

  1. #1

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    DOS-Ordner verschieben in einer Batch Datei funktioniert nicht

    Anzeige
    Hi habe folgendes problem möchte eine batch ertstellen die mir ordner/datein in einen anderen pfad kopieren ich weiß für euch is das easy aber ich habs vergessen wie es geht !

    ich habs so in der batch versucht z.b :

    Code:
    move c:\programme d:\
    pause
    weshalb geht es nicht ?

  2. #2
    Moderator Avatar von xeno
    Registriert seit
    09.09.04
    Danke (erhalten)
    10
    Gefällt mir (erhalten)
    198

    Standard

    geht nicht. move benennt entweder ein verzeichnis um oder schiebt dateien hin und her.
    xcopy wird dir da weiterhelfen, einfach mal xcopy /? eingeben.

  3. #3

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    habs mit copy , move und xcopy versucht immer noch kein erfolg !!!
    bekomme syntax fehler ! oder parameter sind zu falsch

  4. #4

    Registriert seit
    04.02.06
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

  5. #5
    Moderator Avatar von xeno
    Registriert seit
    09.09.04
    Danke (erhalten)
    10
    Gefällt mir (erhalten)
    198

    Standard

    xcopy c:\programme\* d: /e /h

  6. #6

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    Ich glaub ich mach immer noch etwas flasch schaut und lacht ?(

    steht /e/h für den befehl von xcopy oder sollen das pfade sein ?

    könnt ihr mir vielleicht die batch hinschreiben ???
    Angehängte Grafiken Angehängte Grafiken

  7. #7
    Senior Member
    Registriert seit
    03.09.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    Das Leerzeichen verwirrt die Shell, schreib mal den ersten Parameter in Anführungszeichen

  8. #8

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    jetzt sagt er mir nur das der pfad ungülltig ist aber ich hoff ich bin auf dem richtigen weg

    z.b :

    Code:
    @echo on
    xcopy "c:\Programme\ c:\temp /E /H
    pause

  9. #9

    Registriert seit
    23.05.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    xcopy "c:\Programme\ c:\temp /E /H
    Fehlt da nicht ein "

  10. #10

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    xcopy "c:\blabla\" "c:\Temp\" /e /h hab ich auch schon versucht nüx

  11. #11

    Registriert seit
    04.02.06
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    Oh man ich hab da einen Link gepostet den solltest du lesen.

    Shit hapens.

    Code:
    xcopy "C:\programme\*.*" "C:\temp" /S /E /C /H /O /R /Y /D /V
    so geht das !

    mfg

  12. #12

    Registriert seit
    29.03.05
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    Original von shodan
    Oh man ich hab da einen Link gepostet den solltest du lesen.

    Shit hapens.

    Code:
    xcopy "C:\programme\*.*" "C:\temp" /S /E /C /H /O /R /Y /D /V
    so geht das !

    mfg
    Eben nich wieso to hell ?

    und den link hab ich auch gelesen shodan

    problem gelöst durch diese seite :http://www.administrator.de/paramete...der_batch.html
    dennoch danke für den versuch thread close :]
    Angehängte Grafiken Angehängte Grafiken

  13. #13

    Registriert seit
    04.02.06
    Danke (erhalten)
    0
    Gefällt mir (erhalten)
    0

    Standard

    Anzeige
    In dem Bild fehlt das zweite Anführungszeichen!

    mfg

Ähnliche Themen

  1. $_FILES['datei']['name'] mit str_replace ändern, funktioniert nicht.
    Von ba2 im Forum (Web-) Design und webbasierte Sprachen
    Antworten: 17
    Letzter Beitrag: 25.08.09, 07:42
  2. [GELÖST] Probleme mit einer Batch-Datei
    Von Proma im Forum Windows
    Antworten: 8
    Letzter Beitrag: 16.01.08, 15:07
  3. SQL Problem: Daten hinzufügen innerhalb einer schleife funktioniert nicht
    Von ba2 im Forum (Web-) Design und webbasierte Sprachen
    Antworten: 2
    Letzter Beitrag: 23.07.06, 06:31
  4. DLLCache Ordner verschieben
    Von alibaba1001 im Forum Windows
    Antworten: 5
    Letzter Beitrag: 21.07.06, 14:49
  5. PHP-Datei per JS einbinden, funktioniert nicht.
    Von Iker C. im Forum (Web-) Design und webbasierte Sprachen
    Antworten: 12
    Letzter Beitrag: 11.11.03, 16:12

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •