Apache+PHP!!!!!!

BasicAvid

Member
Hallo, habe ein riesen Problem!

Auf meinem NB habe ich einen Apachen mit PHP/MySQL laufen und seit geraumer Zeit führt er mir keinen PHP-Code in HTML-Dateien mehr aus! Woran könnte das liegen? Habe PHPTriad Installiert/deinstalliert und hat nichts gebracht, habe auch noch andere Programme probiert und bei denen ist es das gleiche! Muss ich irgendwas in der PHP.ini eintragen damit das geht?

Sonst ging es aber einwandfrei, nur eben seit geraumer Zeit geht es nicht mehr!
Woran könnte das liegen?
 

PtB

New member
Da wird nicht an der php.ini liegen sondern an der httpd.conf. In dieser Konfigurationsdatei musst du noch ein paar einträge machen um das der apache die PHP dateien zum verarbeiten an PHP weitergibt. Hast du diese Einstellungen gemacht??

z.B.:

ScriptAlias /php/ "Pfad zu PHP"
AddType application/x-httpd-php .php //oder php3 o.ä.
Action application/x-httpd-php "php/php.exe" //für Windows

Schau mal nach ob diese Einträge vorhanden sind!
 

BasicAvid

Member
Danke!!!

AddType application/x-httpd-php .php //oder php3 o.ä.

Das hat mir geholfen! Musste nur wieder .html dran hängen und es ging wieder!
Nur wie sich das selbst rauslöschen kann, ist mir ein Rätsel!

Aber herzlichsten Dank für deine Info, war ein Volltreffer!
 

Zemy

New member
Wieos führst du HTML als PHP aus? ist dafür nicht die Endung .php gedacht? [verwirrt sei]
 

BasicAvid

Member
Ich habe öfters mal normale HTML-Dateien in denen ich PHP-Code drin habe und damit dass geparsed wird musste ich die Zeilen in die httpd.conf einfügen, sonst würde der ganze PHP-Code nur als Text im Browser angezeigt und es wird ja nur der PHP -Code geparsed, HTML braucht er ja nicht parsen!

Ach ja, klar die Endung ".php" ist für PHP gedacht aber wenn ich nur ein paar Zeilen PHP in einer HTML-Datei habe speicher ich das ding nicht gleich als ".php" ab!

Klingt komisch is aber so!
 
Oben