Kali 2.0

#1
Schönen guten Abend Community.
Kali 2.0 ist ja nun schon eine Weile veröffentlicht und ich habe meinen "alten" Laptop (AUSUS F75V) nun ein neues Betriebssystem verschafft.
Alles läuft super, bis auf eine kleine Kleinigkeit XD

Wie zur Hölle bekomme ich mein Wlan zum laufen? Ich weiß das mir der Treiber fehlt, aber nach ewiger Suche habe ich nichts gefunden, wo ich ihn herbekomme und wie ich ihn einbinde -.-

nach Eingabe von lspci wird mir das ausgeworfen:
Ethernet controller: Qualcomm Atheros AR8161 Gigabit Ethernet (rev 10)

Ich danke euch schon mal für eure Hilfe.

Mit freundlichen Grüßen
Rising
 
#3
Ein Gigabit Ethernet Controller hat mit dem WLAN ganz sicher nichts zu tun. In dem Teil dürfte eher ein Realtek RTL8188CE verbaut sein. Dafür sollte ein halbwegs moderner Kernel bereits einen Treiber dabei haben und lediglich die Firmware wird nicht mitgeliefert. Schau also mal in den Output von 'dmesg', was beim Laden des LKM beanstandet wird. Oft gibt die Meldung bereits einen Hinweis darauf welche Datei benötigt wird. Diese besorgst du dir dann im WWW und legst sie in /lib/firmware ab.
 
#5
Schon mal danke für den Hinweis. Es ist eine Ralink verbaut. Firmware-Updates sind jetzt drauf und es geht immer noch nicht.

Naja ich habe jetzt mal beim rfkill nachgesehen und da ist mir folgendes aufgefallen:

Die Operation ist nicht möglich wegen RF-kill

rfkill list all
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes
1: asus-wlan: Wireless LAN
Soft blocked: no
Hard blocked: no
2: asus-bluetooth: Bluetooth
Soft blocked: no
Hard blocked: no

Warum ist da ein Hardblock drin? Und nein ich habe keinen Hardwareschalter um es zu deaktivieren und "FN"+Wifi funktioniert auch nicht......

iwconfig wirft mir nur das wlan0 aus:

wlan0 IEEE 802.11bgn ESSID:eek:ff/any
Mode:Managed Access Point: Not-Associated Tx-Power=off
Retry short limit:7 RTS thr:eek:ff Fragment thr:eek:ff
Encryption key:eek:ff
Power Management:eek:ff

Das Ergebnis kann ich mir durch den rfkill erklären.... Langsam komme ich mir wie ein DAU vor XD.
Habe ich was übersehen?
 
#8
Sooo ich mal wieder -.-
Bin mal wieder mit meinem Latein am Ende.

Wollte heute versucht einen Drucker zum laufen zu bringen unter Kali, jedoch will der nicht drucken. Es handelt sich hier um einen HP Officejet 4658

Er ist über Wlan verbunden, ich konnte ihn über cups auch wie immer einrichten, jedoch kommt nichts raus, wenn ich die Testseite drucken möchte, oder irgendwas anderes. Auf allen anderen Systemen klappt es einwandfrei.

Es ich habe hplip installiert und das lief ohne Probleme durch.

dass Zugriffsprotokoll sagt auch aus, dass alles ok ist:
localhost - - [07/Oct/2016:16:11:52 +0200] "POST /printers/OfficeJet_4650_series HTTP/1.1" 200 423 Print-Job successful-ok
Habt ihr eine Idee, die ich übersehen habe?

Vielen Dank für die Hilfe
 

CDW

Moderator
Mitarbeiter
#9
> Habt ihr eine Idee, die ich übersehen habe?
HP Device Manager (aka hp-toolbox, sollte eigentlich Bestandteil des hplip-Packets sein) starten und schauen, ob unter "Printer Control" Reiter alles "grün" ist. Denn aus unerfindlichen Gründen stoppte bei mir der HP Drucker (angeschlossen über USB) manchmal. Die Druckaufträge usw. wurden allerdings schön brav angenommen (und insgesammt war unter CUPS nichts auffälliges zu sehen).
 
Zuletzt bearbeitet:
#10
Es liegt wahrscheinlich daran, dass hplips, kali nicht unterstützt -.- und verschiedene Dienste nicht installiert hat. So ist zwar die grundsätzliche Kommunikation möglich, aber der Druckauftrag kann nicht richtig übersendet werden.

Die Dienste lassen sich auch nicht nachträglich installieren -.-
Das heißt ich setze jetzt eine VM auf, nur um Drucken zu können^^
 
#11
Druck wie ein richtiger Hacker mit netcat, wenn du schon Kali verwendest:

Code:
nc (drucker-ip) 9100 < textfile.txt
Du solltest zuerst sicherstellen, dass die newlines CR+LF sind (z.B. mit unix2dos).
Und falls der Drucker das Papier nicht ausspuckt, schick ihm ein Form Feed (^L).
 
Oben