kubuntu lüfterkontrolle

#1
Hey, habe auf meinem IBM Thinkpad T41 ein Kubuntu (9.10) laufen. Würde da gerne den 3D-Desktop aktivieren. Das Problem, wenn der Lüfter standartmäßig eingestellt ist surrt er zwar schön leise vor sich hin, allerdings hängt sich das System auch die ganze Zeit auf, weil es zu heiß wird. Jegliche Einstellungsmöglichkeiten die ich per google gefunden habe, u.a. von thinkwiki.de taugen so weit nichts weil sie nicht funktionieren (eine Variante lief hatte einmal funktioniert, damals war ein Fedora installiert, diese geht aber unter Kubuntu nicht, zwar war diese in Terminal eintippen
Code:
# echo level disengaged > /proc/acpi/ibm/fan
)

hoffe es weiß hier jemand noch ne alternative, mit GUI wäre auch ganz nett ^^
 
#3
ja das kenne ich, da liegt das problem da, dass wohl bei version 9.10 die verzeichnisstruktur geändert wurde so das es die datei /etc/modprobe.d/thinkpad-acpi.modprobe nicht mehr gibt, die braucht man aber um die lüftersteuerung zu aktivieren...
 
#4
Hast du alles gelesen? Ich habe leider keinen Thinkpad, kann es nicht ausprobieren.

Ab Kernel 2.6.22 (also ab Ubuntu 7.10 Gutsy Gibbon) heißt das Modul wegen der Übernahme der Notebook-Sparte durch Lenovo allerdings nicht mehr ibm-acpi, sondern thinkpad-acpi. Allerdings sorgt bis Kernel 2.6.29 ein Alias dafür, dass auch der alte Name weiter funktioniert. Erst ab Kernel 2.6.30 bzw. Ubuntu 9.10 Karmic Koala ist der alte Name definitiv nicht mehr gültig.
Zugriff

Ob das Kernelmodul automatisch geladen wurde, lässt sich mittels
lsmod | grep pad

herausfinden. Falls es nicht geladen ist, kann man das durch
sudo modprobe -v thinkpad-acpi

nachholen. Die Komponenten, die über das Modul angesteuert werden können, finden sich im Verzeichnis /proc/acpi/ibm. Sie werden alle auf dieselbe Weise angesprochen.
Hinweis:

Der Zugriff über /proc/acpi/ibm gilt inzwischen als veraltet. Stattdessen sollte der Zugriff bei neueren Kerneln (Faustregel: 2.6.29 und neuer) über die Ordner /sys/devices/platform/thinkpad_acpi/ und /sys/devices/platform/thinkpad_hwmon/ erfolgen (siehe auch Verzeichnisstruktur und ThinkWiki
).
Beispiel: cat /sys/devices/platform/thinkpad_acpi/bluetooth_enable liefert für BlueTooth den Wert 0 (deaktiviert) zurück. Aktivieren von BT mit echo 1 | sudo tee /sys/devices/platform/thinkpad_acpi/bluetooth_enable.
 
#5
ja das hat aber nichts mit meinem oben genannten problem zu tun das die datei /etc/modprobe.d/thinkpad-acpi.modprobe nicht mehr aufzufinden ist ...
 
#6
Poste bitte mal die Ausgabe von lsmod!

EDIT:
Die Datei "/etc/modprobe.d/thinkpad-acpi.modprobe" kannst du selbst anlegen, der Inhalt der Datei ist im Artikel beschrieben, und auch welche Optionen du in der Datei setzen kannst, um in die Register des Laptops zu schreiben.
 
Zuletzt bearbeitet:

rami

New member
#7
Die Datei "/etc/modprobe.d/thinkpad-acpi.modprobe" kannst du selbst anlegen, der Inhalt der Datei ist im Artikel beschrieben, und auch welche Optionen du in der Datei setzen kannst, um in die Register des Laptops zu schreiben.
Wenn er meint, die Dateistruktur wurde geändert, dann würde es doch effektlos sein, die Datei selbst anzulegen oder liege ich da falsch?
 
#8
modprobe ließt alle Dateien in /etc/modprobe.d/ aus und lädt die Module entsprechend der Einstellungen in den einzelnen Dateien.

Ich arbeite grade mit Ubuntu 9.10, das passt :wink:
 
#9
falls du mit lsmod drauf hinauswillst ob das modul thinkpad-acpi geladen ist, ja es ist geladen .... habe ich auch bereits getestet, und das mit dem selber anlegen denke ich doch auch, das das nich geht, wäre doch zu einfach oder ?!
 
#10
Mensch............in dem Artikel steht alles drin. Bitte meine Ausführungen erst in Frage stellen, wenn ihr es auch ausprobiert.

Es steht ganz eindeutig da

Ab Ubuntu 7.10 sind Manipulationen am Lüfter nur möglich, wenn das thinkpad-acpi-Modul mit der Option experimental=1 fan_control=1 geladen wird. Ein entprechender Eintrag muss also in der Datei /etc/modprobe.d/thinkpad_acpi.modprobe stehen.
Wenn eine entsprechende Datei in /etc/modprobe.d/ nicht vorhanden ist, dann kann die Option auch nicht gesetzt sein, ergo kannst du den Lüfter nicht steuern. Bitte lege die Datei an, schreibe den entsprechenden Inhalt rein und boote einmal durch. Wenn es dann immer noch nicht geht, DANN dürft ihr mit mir meckern.
 
#13
ich benutze die auf der ubuntu.wiki seite beschrieben befehle also das bash -s echo level 7 > /proc/acpi/ibm/fan, aber naja tut sich halt einfach nichts trotz der geschriebenen Optionen wie oben...
 
#14
Bitte versuch mal echo level 7 | sudo tee /proc/acpi/ibm/fan

Das ganze muss natürlich als root respektive mit sudo passieren.

Wenn das nicht geht, wäre interessant, ob das Modul auch mit den Optionen geladen wurde.
 
#15
also bei echo level 7 bekomm ich nur die ausgabe "level 7" .. logisch, und naja bei tee bekomme ich "invalid argument", habe das ganze natürlich als root getestet, alles andere wäre ja sinnfrei ^^
 
#16
Wenn du es richtig eingibst, dann dürfte die Ausgabe "Level 7" gar nicht erscheinen, weil diese ja in /proc/acpi/ibm/fan umgeleitet wird. Sehr merkwürdig.

Wenn du vorher per sudo su Root Rechte erlangt hast, und dann ein echo level 7 > /proc/acpi/ibm/fan eingibst, dann erscheint level 7 auf der Konsole?
 
Oben