Java 8 DeploymentRuleSet

selig

Member
Hallo,

ich hoffe das passt hier rein...

Und zwar habe ich das Problem das ich mit Java-8 im ControlPanel nicht mehr die Möglichkeit habe, die Sicherheitseinstellungen auf "mittel" zu setzen. Ich habe aktuell ca 80Maschinen auf die ich via Browser zugreifen sollte, die Java 8 vorraussetzen, die allerdings ein abgelaufenes Zertifikat haben... - Ergo: Java verhindert das ausführen dieser Applets -.-

Natürlich könnte ich alle 80Kisten in die Ausnahmenliste eintippseln, was aber auch wieder doof ist, weil sich da in den nächsten Jahren einiges ändern wird. Deswegen habe ich gelesen (und ich zweifel gerade ob das stimmt).
das man mit dem DeploymentRuleSet eine Whitelist mit Wildcards erstellen kann. (also z.B. https://10.20.*.* ) - das nimmt Java zwar so hin, aber ich bekomm immernoch die Meldung, dass das Ausführen des Applets Aufgrund des abgelaufenen Zertifikats blockiert wurde.

aktuell hab ich folgendes ruleset.xml
Code:
<ruleset version="1.0+">
    <rule>
        <id location="https://10.20.*.*" />
        <action permission="run" />
    </rule>
</ruleset>


Ich hoffe jemand hat damit schon erfolgreiche Erfahrungen gesammelt und kann mir helfen ;)

Grüße
Selig
 
Oben