Frage zu W-LAN Adapter

Chef32

Member
Hallo, ich habe eine Frage. Und zwar teste ich gerade einen W-LAN Stick, um damit ins Netz zu kommen. Jetzt ist es so, dass der Stock kaputt ist, das heißt, die Verkleidung ist abgebrochen, die Platine selbst ist aber in Ordnung, es kann also nicht daran liegen. Es ist so, dass ich kaum Signal meines Netzwerkes empfange - und die anderen empfängt er gar nicht. Brauche ich nicht, aber mein Laptop selbst, also der integrierte Chip, empfängt fast 10 Netze. Ist der Stick doch defekt oder einfach nur "schlecht"? Ich betreibe den Stick in einer virtuellen Umgebung, aber daran kann es ja sicher nicht liegen.


Noch eine andere Frage. Ich habe ferner die MAC Adresse des Sticks gespooft, das heißt, ich habe mittels eines Reg. Hack eine falsche, aber dennoch gültige MAC Adresse generiert. Nach Ausführen diverser Befehle in der Konsole (ipconfig; getmac etc.), kann man feststellen, dass tatsächlich die falsche MAC Adresse genutzt wird.
Zur Sicherheit habe ich auch noch den Traffic mit Wireshark mitgeschnitten - auch hier wird nur die falsche MAC Adresse übertragen, außer natürlich die korrekte des Routers (ich bin ja im eigenen Netz).


Hierzu auch eine Frage: eig. kann man die MAC nicht auf Dauer "gefälscht" lassen. Wann kontrolliert das System bzw. Windows, ob es sich um die korrekte MAC handelt bzw. wann liest Windows die korrekte wieder ein?


Kann man die Änderung der MAC in der Ereignisanzeige sehen? Das geht sicher, nur wo (habe den Laptop nun schon wieder aus un kann jetzt nicht nachschauen)?


Wenn ich mit einem anderen Rechner, also einem über LAN betriebenen, Wireshark ausführe, dann müsste ich doch eigentlich den Traffic des Laptops sehen, oder? Ich sehe nur, dass eine Meldung kommt, "wer" eben die gespoofte MAC ist bzw. die IP des Rechners. Könnte es daran liegen, dass die MAC gespooft ist? Oder kann ich dies nur ebenfalls mit einem W-LAN fähigen Gerät machen? Da bin ich mir grad unsicher. Aber alles wird durch den Router "geschleift".

Edit: Ich sehe gerade, wäre vielleicht besser gewesen, den Thread in der "WLAN Zone" unterzubringen. Aber es handelt sich bei mir ja auch um "Network" Fragen an sich.
 
Zuletzt bearbeitet:

GrafZahl

Member of Honour
klingt als wäre das antennenelement beschädigt ...


was dein gespoofe angeht, wer sagt dir denn das eine MAC "falsch" ist?

sagen wir mal eine MAC beginnt in LSB schreibweise binär mit 01.....

die kann nicht falsch sein ... per order de mufti nicht ... denk mal drüber nach und les ggf. die spezifikation...



zum thema "ja aber warum seh ich denn den traffic nicht?"


dein router/AP enthält einen integrierten switch (handelsüblich mit vermutlich 4 ports extern + X intern für den AP/router) ...

switches haben die tolle eigenschaft, dass sie daten portbasiert weitergeben, und zwar nur an den port hinter dem laut ARP-cache der zielhost liegt ... tolle sache... dadurch stört man die anderen netzwerkteilnehmer nicht in dem man ihnen den nutzlosen traffic der sie überhaupt nix angeht auch nicht auf den port legt ...

abgesehen davon, kann es auch sein, dass dein router den switch für den AP teil komplett in software realisiert und bei WAN traffic, die daten die über den AP kommen erst gar nicht zum switch durch lässt, sondern gleich ins routing nimmt ...

kurzum ... evtl kann dir APR weiterhelfen, vermutlich klappt aber nichtmal das für inet traffic aus dem wlan
 

Chef32

Member
Ja, dass das kann natürlich sein, der Adapter kann auch "einfach so" beschädigt sein.


gespoofe angeht, wer sagt dir denn das eine MAC "falsch" ist?


Ja, ich hab ja natürlich die originale und die jetzige Überprüft - die "neue" MAC Adresse ist falsch. Natürlich nicht falsch im Sinne von "ungültig", sondern eher so, dass sie eben eigentlich nicht von diesem Gerät stammt.


handelsüblich mit vermutlich 4 ports extern


Ja, vier RJ45 Buchsen, korrekt.


ARP-cache der zielhost liegt


Dies könnte man natürlich auch manipulieren, aber das will ich ja nicht.


sondern gleich ins routing nimmt ...




Wo kann ich denn diese Spezifikation nachlesen?


evtl kann dir APR weiterhelfen


Meinst du auch hier zu spoofen?




Mich hat es insoweit etwas irritiert. Ich hab kürzlich im Netz was zum Thema "Probleme im Netzwerk gelesen". Dort wird vorgeschlagen, mit Wireshark den Traffic zu analysieren, um den Fehler zu finden. In diesem Fall war es so, dass ein Rechner massiv RTMP Daten empfangen wurden - dadurch war das Netzwerk sehr langsam. Wie soll man das nun rausfinden?


Hier bei mir habe ich ein Problem, dass ein Laptop, der per W-LAN im Netz ist, immer aussteigt. Das würde ich gerne näher betrachten.

Ich möchte auch betonen, dass ich nichts Illegales machen möchte.

Edit: Aber wenn es so wäre, wie von dir vermutet, dürfte ich auch nicht den Traffic meines Smartphones mitscannen können, oder? Aber genau das ist der Fall.
 
Zuletzt bearbeitet:
Oben