FritzBox -> OpenWrt Router -> IPv6 Einstellungen

Hallo Coummunity,

Habe am Freitag auf einem Router (Linksys WRT32X) OpenWrt installiert. Dabei habe ich bemerkt, dass mein Provider heimlich IPv6 freigeschaltet hat. So weit so gut.
Ich hab mich per SSH beim Router eingeloggt und per ping6 einfach mal Google angepingt, mit Erfolg.

Folgendes Setup habe ich derzeit:

DSL -> FritzBox -> WRT32X -> Zu den anderen Geräten

Das Problem was ich jetzt aber habe ist, dass zwar auf OpenWrt ein ping über IPv6 möglich ist, aber bei den anderen Geräten IPv6 nicht verfügbar ist bzw. nicht richtig konfiguriert ist. Wenn ich aber die anderen Geräte direkt an die FritzBox anschließe bzw. mit der FritzBox verbinde dann funktioniert IPv6.

Da für mich IPv6 noch Neuland ist, woran kann es liegen? Auch benutze ich das erste mal OpenWrt. Habe bei den Einstellungen von OpenWrt zwecks IPv6 nichts geändert.
 

end4win

Member of Honour
Wie sind die Geräte sonst angeschlossen.
Erste Verdächtige sind Router oder Managed Switches in denen IPv6 nicht konfiguriert ist.

Gruß
 
Die Geräte sind mit dem Router (WRT32X) teilweise über LAN und WLAN verbunden.

Derzeit wäre es mir aber nur wichtig, wenn bei meinem Arbeitsgerät IPv6 funktioniert was über LAN am WRT32X angeschlossen ist.
Die anderen Geräte ist mir zwischenzeitlich mal egal, ob IPv6 funktioniert.

Mein Ziel wäre es also mal bei meinem Arbeitsgerät eine funktionierende IPv6 Verbindung herzustellen. Allerdings eine statische IP Adresse.
Hab es jetzt aufgrund der Tests mal dynamisch versucht. Aber ohne Erfolg.

Hab derzeit das folgende Problem:
If the router can ping6 the internet, but lan machines get “Destination unreachable: Unknown code 5” or “Source address failed ingress/egress policy” then the ip6assign option is missing on your lan interface
Quelle: OpenWrt - User Guide - IPv6

Wobei im LAN interface die Option ip6assign sehr wohl präsent ist:
Code:
$ cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd00:db80::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '10.42.42.1'
        option ip6assign '60'
        option ip6hint '10'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'
$
Kann hier bitte mal wer darüber schauen und mich hinweisen was hier falsch ist?
 
Hab das Problem gefunden, warum das Vorhaben ohne NAT nicht funktioniert.

Und zwar liegt es an der FritzBox. Die benötigt mindestens ein Netz größer als 64 Bit für Prefix Delegation und ich habe vom Provider "nur" ein Netz mit 64 Bit. Somit fällt diese Variante weg. Versuche es mit Relay. Bin aber noch nicht auf einem grünen Zweig damit. Will nicht so recht funktionieren....
 

kaputtnik

Stammuser
Das wird die Fritzbox wahrscheinlich wegen Slaac unterbinden, wobei es schon dreist von deinem Anbieter ist, dir so ein kleines Netz zuzuweisen.
 
Oben