[gelöst] Problem Firefox/Apache/JS

sTEk

New member
Ich habe eine "lustige" Konstellation mt einem Fehler, der sich meiner Logik entzieht...

Ich habe nach einer Neuinstallation auf einem Win7-Rechner XAMPP laufen (nur Apache & SQL). Wenn ich auf diesem Rechner mittels FireFox auf eine interne Seite zugreife, dann lädt FireFox einige JS-Dateien nicht bzw. nicht richtig. Es werden lt. Firebug-Netzwerkkontrolle einfach weitere Daten (z.B. der Bereich nach dem "<script>"-Aufruf) an das JS-Dokument angehangen - erst der Header des Folgefiles und dann der Inhalt - völlig irrational! Im IE funktioniert alles prima, ebenso auf anderen Rechnern im Netzwerk, die den Server in Anspruch nehmen.

Anfrage-Header:
Accept */*
Accept-Encoding gzip, deflate
Accept-Language de-de,de;q=0.8,en-us;q=0.5,en;q=0.3
Cache-Control max-age=0
Connection keep-alive
Cookie PHPSESSID=kklkhgj1rd4ujet15fsc6fjk14
Host lxxx.intneu
If-Modified-Since Wed, 22 May 2013 12:28:47 GMT
Referer http://lxxx.intneu/Kunden
User-Agent Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0


Antwort-Header:
Cache-Control max-age=216000, private
Connection Keep-Alive
Date Fri, 24 May 2013 12:47:28 GMT
Keep-Alive timeout=5, max=98
Server Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1



Auszug aus Antwort:

HTML:
// JavaScript Document

function object_len(obj) {
  var result = 0;
  for (var key in obj) {
    // hasOwnProperty == true, dann objektimmanent = !prototypisch
    // hasOwnProperty == false, dann prototypisch = !objektimmanent
    // Umwandlung zu Number true -> 1 und false -> 0:
    result += Object.prototype.hasOwnProperty.call(obj, key);
  }
  return result;
}

HTTP/1.1 200 OK
Date: Thu, 23 May 2013 14:50:05 GMT
Server: Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1
Last-Modified: Mon, 15 Apr 2013 12:54:13 GMT
Accept-Ranges: bytes
Content-Length: 5159
Cache-Control: max-age=216000, private
Keep-Alive: timeout=5, max=96
Connection: Keep-Alive
Content-Type: application/javascript

// JavaScript Document


$(document).ready(function() {
...

Als noch WinXP im Einsatz war klappte alles tadellos - leder hatte sich das Board des Bartons nach 10 höchstgetakteten Jahren verabschiedet... ^^
 
Zuletzt bearbeitet:

Brabax

New member
Das klingt, als hättest du die Dateien von A nach B kopiert.
Ich hatte es schon des öfteren, dass durch Übertragungsfehler Steuerzeichen oder ähnliches in die Dokumente gerutscht sind, die dann zu den merkwürdigsten Situationen führten.

Vielleicht hilft es bereits, die Dateiinhalte neu zu erstellen.

lG
 

Chakky

Member of Honour
Das klingt, als hättest du die Dateien von A nach B kopiert.
Ich hatte es schon des öfteren, dass durch Übertragungsfehler Steuerzeichen oder ähnliches in die Dokumente gerutscht sind, die dann zu den merkwürdigsten Situationen führten.

Vielleicht hilft es bereits, die Dateiinhalte neu zu erstellen.

lG

Würde ich so zustimmen, schau dir mal mit einen Editor (notepad) langt. Ich hatte das mal mit ein paar PHP files. In meinen Netbeans sah alles normal aus aber mit Notepad waren am Anfang noch 2 oder 3 Zeichen drinne.....
 

sTEk

New member
Sooo...ich habe es! Mit dem Kopieren liegt ihr nicht so falsch - aber trotzdem knapp daneben. ;)

Das Problem mit den ein oder zwei "unsichtbaren" Zeichen löse ich immer via Hex-Editor, meist merkt man das beim Weigern des PHP-Servers, eine Session anzulegen. (Wobei ich mich immer frage, wie das passieren kann und warum andere Daten davon irgendwie nie [Oder merkt man es bloß nicht?] betroffen sind.)

Mein sehr guter Freund Schinken war zufällig da und da zeigte ich ihm die Ungereimtheit. Und während ich ihm zeigte, was so komisch ist und was ich gemacht habe, kam ich für mich selbst auf die Lösung. Als alte Support-Hu*e fragte er mich auch gleich, ob ich es mal mit einem frischen Konto versucht habe - und siehe da, wie schon im IE des anderen Profils lief auch auf dem FF alles.

Was es war? Da bei Mozilla kein Kommentar zu Inkompatiblitäten angegeben waren, habe ich das Firefox-Profil des 32Bit-XP-Benutzers mit samt seinen Add-Ons als neues Profil des 64Bit-Windows7-Benutzers kopiert. Da liegt wohl der Hase im Pfeffer - irgendwas funktioniert da wohl doch nicht richtig - oder sollte ich nicht nachhaltig sagen? ^^

Und die Worte des Schinken? "Es freut mich, dass wir das Problem so schnell lösen konnten und wünsche noch weiterhin viel Spaß mit unseren Produkten!"
 
Oben