[Gentoo] Wlan RTL8191SU [SOLVED]

benediktibk

Standardgruppe für nicht aktivierte User
#1
Mein heutiges Problem: Ein Wlan USB-Dongle mit einem RTL8191SU. Der Treiber ist bereits im Kernel, Firmware scheint auch die richtige da zu sein:
Code:
[    1.113911] usbcore: registered new interface driver r8712u
[    1.877107] r8712u: Staging version
[    1.878008] r8712u: register rtl8712_netdev_ops to netdev_ops
[    1.878868] usb 1-1.2: r8712u: USB_SPEED_HIGH with 4 endpoints
[    1.880158] usb 1-1.2: r8712u: Boot from EFUSE: Autoload OK
[    3.132359] usb 1-1.2: r8712u: CustomerID = 0x000a
[    3.133362] usb 1-1.2: r8712u: MAC Address from efuse = 24:05:0f:27:17:22
[    3.134368] usb 1-1.2: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[    8.364148] r8712u 1-1.2:1.0 wlp0s26u1u2: renamed from wlan1
[   99.385220] r8712u 1-1.2:1.0 wlp0s26u1u2: 1 RCR=0x153f00e
[   99.385967] r8712u 1-1.2:1.0 wlp0s26u1u2: 2 RCR=0x553f00e
Wenn ich aber versuche das Wlan zu starten passiert folgendes:
Code:
crub-gentoo ~ # /etc/init.d/net.wlp0s26u1u2 start
net.wlp0s26u1u2  | * Bringing up interface wlp0s26u1u2
net.wlp0s26u1u2  | *   Starting wpa_supplicant on wlp0s26u1u2 ...
net.wlp0s26u1u2  |Successfully initialized wpa_supplicant
net.wlp0s26u1u2  |nl80211: Could not configure driver mode
net.wlp0s26u1u2  |wlp0s26u1u2: Failed to initialize driver interface
net.wlp0s26u1u2  | *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'                                                                                                      [ !! ]
net.wlp0s26u1u2  | * ERROR: net.wlp0s26u1u2 failed to start
Das init-Skript ist übrigens nur ein Link auf /etc/init.d/net.lo. Ich vermute ganz stark, dass es irgendwie an Treiber oder ähnlichem liegt, weil die interne Wlan-Karte funktioniert einwandfrei.

Weiß jemand Rat?
benediktibk
 
Zuletzt bearbeitet:
#2
Schau mal in's Systemlog ob dort weitere Meldungen beim Ausführen des Init-Skripts erscheinen. Irgendwo muss ja auch geloggt werden welches Interface er da konfiguriert (könnte ja ggf. das Falsche sein) u.ä..
 
#3
wlan

Hallo

Kannst du mal testweise die interne wlan-Karte ausbauen (oder ist das ein Schleppi?) und nur den USB-dongle laufen lassen ?

mfg
schwedenmann
 

benediktibk

Standardgruppe für nicht aktivierte User
#4
Das andere Wlan-Modul ausbauen spielt sich leider nicht, das ist nämlich das integrierte im Laptop.

In den logs hätte ich jetzt nicht viel sinnvolles gefunden, aber ich poste mal trotzdem was ich so zu bieten habe (nach einem Versuch das Wlan zu starten):

dmesg
Code:
[ 4433.789601] usb 2-1.1: new high-speed USB device number 5 using ehci-pci
[ 4433.877533] usb 2-1.1: New USB device found, idVendor=0bda, idProduct=8172
[ 4433.877543] usb 2-1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4433.877558] usb 2-1.1: Product: RTL8191S WLAN Adapter 
[ 4433.877563] usb 2-1.1: Manufacturer: Manufacturer Realtek 
[ 4433.877568] usb 2-1.1: SerialNumber: 00e04c000001
[ 4433.878187] r8712u: Staging version
[ 4433.878200] r8712u: register rtl8712_netdev_ops to netdev_ops
[ 4433.878204] usb 2-1.1: r8712u: USB_SPEED_HIGH with 4 endpoints
[ 4433.878645] usb 2-1.1: r8712u: Boot from EFUSE: Autoload OK
[ 4434.442572] usb 2-1.1: r8712u: CustomerID = 0x000a
[ 4434.442583] usb 2-1.1: r8712u: MAC Address from efuse = 24:05:0f:27:17:22
[ 4434.442589] usb 2-1.1: r8712u: Loading firmware from "rtlwifi/rtl8712u.bin"
[ 4434.452948] r8712u 2-1.1:1.0 wlp0s29u1u1: renamed from wlan0
[ 4434.462064] systemd-udevd[3291]: renamed network interface wlan0 to wlp0s29u1u1
[ 4548.646142] r8712u 2-1.1:1.0 wlp0s29u1u1: 1 RCR=0x153f00e
[ 4548.646865] r8712u 2-1.1:1.0 wlp0s29u1u1: 2 RCR=0x553f00e
[ 4548.752284] IPv6: ADDRCONF(NETDEV_UP): wlp0s29u1u1: link is not ready
rc.log
Code:
dbus             | * Starting D-BUS system messagebus ...
net.enp9s0       | * Bringing up interface enp9s0
net.wlp3s0       | * Bringing up interface wlp3s0
sshd             | * Starting sshd ...
 [ ok ] [ ok ]

consolekit       | * Starting ConsoleKit daemon ...
 [ ok ]
net.enp9s0       | *   Starting ifplugd on enp9s0 ...
 [ ok ]
net.enp9s0       | *     Backgrounding ...
net.enp9s0       | * WARNING: net.enp9s0 has started, but is inactive
net.wlp3s0       | *   Starting wpa_supplicant on wlp3s0 ...
net.wlp3s0       |Successfully initialized wpa_supplicant
 [ ok ]
net.wlp3s0       | *   Starting wpa_cli on wlp3s0 ...
 [ ok ]
netmount         | * WARNING: netmount is scheduled to start when net.enp9s0, net.wlp3s0 has started
net.wlp3s0       | *   Backgrounding ... ...
net.wlp3s0       | * WARNING: net.wlp3s0 has started, but is inactive
dropbox          | * WARNING: dropbox is scheduled to start when net.enp9s0, net.wlp3s0 has started
cupsd            | * Starting cupsd ...
xdm              | * Setting up kdm ...
 [ ok ]
 [ ok ]
alsasound        | * Restoring Mixer Levels ...
cups-browsed     | * Starting cups-browsed ...
 [ ok ]
 [ ok ]
mpd              | * Starting Music Player Daemon ...
 [ ok ]
local            | * Starting local
 [ ok ]

rc default logging stopped at Tue Jan  6 12:18:36 2015
/etc/init.d/net.wlp0s29u1u1 start
Code:
net.wlp0s29u1u1  | * Bringing up interface wlp0s29u1u1
net.wlp0s29u1u1  | *   Starting wpa_supplicant on wlp0s29u1u1 ...
net.wlp0s29u1u1  |Successfully initialized wpa_supplicant
net.wlp0s29u1u1  |nl80211: Could not configure driver mode
net.wlp0s29u1u1  |wlp0s29u1u1: Failed to initialize driver interface
net.wlp0s29u1u1  | *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'                                                                                                      [ !! ]
net.wlp0s29u1u1  | * ERROR: net.wlp0s29u1u1 failed to start
Viel mehr gibt /var/log/ nicht her.

Ein wenig eigenartig finde ich noch das hier:
Code:
crub-gentoo log # iw dev
phy#0
        Interface wlp3s0
                ifindex 3
                wdev 0x1
                addr 74:e5:0b:86:50:b0
                type managed
                channel 6 (2437 MHz), width: 20 MHz, center1: 2437 MHz
In iwconfig ist das Gerät nämlich vorhanden:
Code:
crub-gentoo log # iwconfig
enp9s0    no wireless extensions.

wlp0s29u1u1  unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

lo        no wireless extensions.

wlp3s0    IEEE 802.11bgn  ESSID:"AAAAAAAAAAAA"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 20:4E:7F:06:F5:62   
          Bit Rate=1 Mb/s   Tx-Power=14 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=48/70  Signal level=-62 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:9  Invalid misc:509   Missed beacon:0
Falls ihr gerne noch mehr logs sehen würdet müsst ihr mir nur sagen welche interessant wären.

mfg benediktibk
 
Zuletzt bearbeitet:
#5
wlan

Hallo

Was steht denn

a. in der /etc/network/interfaces

b. wpa_supplicant.conf

und zu guter letzt, kannst du den Treiber des internen wlan blacklisten, sodaß der nicht geladen wird?

mfg
schwedenmann
 

benediktibk

Standardgruppe für nicht aktivierte User
#6
/etc/wpa_supplicant/wpa_supplicant.conf (in echt mit ein paar network-Blöcken mehr)
Code:
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=wheel
ctrl_interface_group=0
update_config=1

network={
        ssid="AAAAAAAAAAA"
        psk="BBBBBBBBBBBBB"
        priority=9
}
/etc/network/interfaces gibt es nicht, dafür aber eine leere /etc/conf.d/net.
 
#7
wlan

Hallo

Müssen nicht in der net die Karten definiert werden, du hast ja jetzt 2, zumindest ein Eintrag a la wlan0 sollte doch vorhanden sein.
Ich habe nämlich keine Ahnung wie wpa_supplicant wlan0 und/oder wlan1 auseinanderhalten soll, außer über die MAC, oder es sollten doch 2 Einträge in der wpa_supplicant vorhanden sein, oder wie ich das kenne, 2 Einträge in interfaces.

blackliste mal den Treiber der internen Karte ud dschau ob der USB-dongle dann funktioniert.

mfg
schwedenmann
 

benediktibk

Standardgruppe für nicht aktivierte User
#8
So, vorher war ich leider im Stress weswegen ich das Ausschalten der interne Karte nicht mehr ausprobieren konnte. Nachdem ich dafür kein Modul verwende habe ich eine Version vom Kernel ohne den passenden Treiber gebaut. Ergebnis: der USB-Dongle geht immer noch nicht. Allerdings kommt eine andere Fehlermeldung.

Code:
crub-gentoo ~ # /etc/init.d/net.wlp0s29u1u1 start
net.wlp0s29u1u1  | * Bringing up interface wlp0s29u1u1
net.wlp0s29u1u1  | *   Starting wpa_supplicant on wlp0s29u1u1 ...
net.wlp0s29u1u1  |Successfully initialized wpa_supplicant
net.wlp0s29u1u1  |nl80211: Driver does not support authentication/association or connect commands
net.wlp0s29u1u1  |wlp0s29u1u1: Failed to initialize driver interface
net.wlp0s29u1u1  | *   start-stop-daemon: failed to start `/usr/sbin/wpa_supplicant'                                                                                                      [ !! ]
net.wlp0s29u1u1  | * ERROR: net.wlp0s29u1u1 failed to start
crub-gentoo linux # iw dev
crub-gentoo linux #
crub-gentoo linux # iwconfig
enp9s0    no wireless extensions.

wlp0s29u1u1  unassociated  Nickname:"rtl_wifi"
          Mode:Auto  Access Point: Not-Associated   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

sit0      no wireless extensions.

lo        no wireless extensions.
Ich mache mich jetzt mal auf die Suche ob ich wpa_supplicant da anderes konfigurieren muss.

mfg benediktibk
 

benediktibk

Standardgruppe für nicht aktivierte User
#9
Des Rätsels Lösung: der Treiber für den USB-Dongle benötigt wext in wpa_supplicant anstelle von nl80211.
Mit
Code:
crub-gentoo ~ # wpa_supplicant -Dwext -iwlp0s26u1u1 -c/etc/wpa_supplicant/wpa_supplicant.conf
bekomme ich das Ding zum Laufen. Zumindest kann ich, nachdem ich die IP per Hand gesetzt habe, das Gateway anpingen.
Die Info habe ich übrigens von Gentoo Forums :: View topic - r8712u fails at life

Jetzt muss ich dann nur mehr rausfinden wie ich das automatisch hin bekomme, aber das werde ich hoffentlich schaffen. Ansonsten bin ich einfach wieder lästig :D.

Danke für die Hilfe,
benediktibk
 

benediktibk

Standardgruppe für nicht aktivierte User
#10
So, die endgültige Lösung:
/etc/conf.d/net
Code:
modules_wlp3s0="wpa_supplicant"
wpa_supplicant_wlp3s0="-Dnl80211"
config_wlp3s0="dhcp"

modules_wlp0s26u1u1="wpa_supplicant"
wpa_supplicant_wlp0s26u1u1="-Dwext"
config_wlp0s26u1u1="dhcp"
mfg benediktibk
 
Oben