ip subnetz über openvpn an mikrotik

tassilo

Stammuser
moin moin

wollte nur mal grundsätzlich fragen ob es geht, denn ich bekomms nicht hin.
ich baue mit meiner mikrotik eine vpn verbindung zu einen hetzner rechner -> das tut.
nun möchte ich aber eines meiner /29 er netze über diese vpn verbindung auf meine tik legen so das ich zuhause -theoritisch- 6 feste ip's hätte.
ein zugegebener massen recht blauäugiges "route add -net 46.4.106.152 netmask 255.255.255.248 gw 192.168.50.2" tats jedenfalls nicht.
auch das netz direkt über openvpn zu pushen tuts nicht. ich sehe zwar dann auf meiner tik das automatisch das /29er netz angelegt wurde aber es laufen keine daten drüber.
( openvpn.conf teil :
route 46.4.106.152 255.255.255.248
push "route 46.4.106.152 255.255.255.248"
)
geschichten wie sysctl -w net.ipv4.ip_forward=1 hab ich nat. gemacht.

falls jemand ne idee hat wär ich dankbar

grüße

tassilo
 

Linus

Stammuser
Ganz spontan behaupte ich mal, dass die eine Richtung weiß, wie sie hin kommt, aber die andere nicht zurück. Also ist die Route auf beiden Seiten gesetzt?

Und poste vlt. auch mal die Config Dateien.
 

tassilo

Stammuser
meine openvpn config...

Code:
root@asterix:/etc/openvpn# cat openvpn.conf 
dev tun
local 88.198.165.219
proto tcp 
port 1194 

script-security 2

ca /etc/openvpn/easy-rsa/2.0/keys/ca.crt
cert /etc/openvpn/easy-rsa/2.0/keys/server.crt
key /etc/openvpn/easy-rsa/2.0/keys/server.key
dh /etc/openvpn/easy-rsa/2.0/keys/dh1024.pem

server 192.168.50.0 255.255.255.0
persist-key
persist-tun

#status openvpn-status.log
verb 1
client-to-client

log-append /var/log/openvpn

plugin /usr/lib/openvpn/openvpn-auth-pam.so login
client-cert-not-required
username-as-common-name

management localhost 7505

route 46.4.106.152 255.255.255.248
push "route 46.4.106.152 255.255.255.248"
root@asterix:/etc/openvpn#

meine mikrotik settings
Code:
[admin@MikroTik] > /export 
# oct/11/2015 21:12:56 by RouterOS 6.33rc22
# software id = I3AV-SUJ5
#
/interface bridge
add admin-mac=4C:5E:0C:E4:2D:2B auto-mac=no name=bridge-local
/interface ethernet
set [ find default-name=ether1 ] name=ether1-gateway
set [ find default-name=ether2 ] name=ether2-master-local
set [ find default-name=ether3 ] master-port=ether2-master-local name=ether3-slave-local
set [ find default-name=ether4 ] master-port=ether2-master-local name=ether4-slave-local
set [ find default-name=ether5 ] master-port=ether2-master-local name=ether5-slave-local
set [ find default-name=ether6 ] name=ether6-master-local
set [ find default-name=ether7 ] master-port=ether6-master-local name=ether7-slave-local
set [ find default-name=ether8 ] master-port=ether6-master-local name=ether8-slave-local
set [ find default-name=ether9 ] master-port=ether6-master-local name=ether9-slave-local
set [ find default-name=ether10 ] master-port=ether6-master-local name=ether10-slave-local
/interface ovpn-client
add connect-to=VPNSERVER mac-address=FE:AB:2D:15:C6:3F name=nirvana password=PASSWORD user=USER
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/interface bridge port
add bridge=bridge-local interface=ether2-master-local
add bridge=bridge-local interface=ether6-master-local
/ip settings
set accept-redirects=yes
/ip address
add address=192.168.3.100/24 comment="default configuration" interface=bridge-local network=192.168.3.0
/ip dhcp-client
add comment="default configuration" dhcp-options=hostname,clientid disabled=no interface=ether1-gateway
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="default configuration" protocol=icmp
add chain=input comment="default configuration" connection-state=established,related
add action=drop chain=input comment="default configuration" in-interface=ether1-gateway
add action=fasttrack-connection chain=forward comment="default configuration" connection-state=established,related
add chain=forward comment="default configuration" connection-state=established,related
add action=drop chain=forward comment="default configuration" connection-state=invalid
add action=drop chain=forward comment="default configuration" connection-nat-state=!dstnat connection-state=new \
    in-interface=ether1-gateway
/ip firewall nat
add action=masquerade chain=srcnat comment="default configuration" out-interface=ether1-gateway
/system clock
set time-zone-name=Europe/Berlin
/system logging
set 0 action=echo disabled=yes
set 1 action=echo
set 2 action=echo disabled=yes
add action=echo disabled=yes topics=ovpn
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes

meine routen


Code:
[admin@MikroTik] /ip route> print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADS  0.0.0.0/0                          192.168.3.1               1
 1 ADS  46.4.106.152/29                    192.168.50.5              1
 2 ADC  192.168.3.0/24     192.168.3.100   bridge-local              0
                                           ether1-gateway    
 3 ADS  192.168.50.0/24                    192.168.50.5              0
 4 ADC  192.168.50.5/32    192.168.50.6    nirvana                   0
[admin@MikroTik] /ip route>
 
Zuletzt bearbeitet:

Linus

Stammuser
Dein push route command in der Server config schaut für mich ein wenig seltsam aus... Eigentlich sollte es im Formate network/IP [netmask] [gateway] [metric] sein. 2. Bei deinem MikroTik schaut es so aus, als würde route2 nicht stimmen, das Gateway ist 192.168.50.5 sollt aber, wenn man von den Standardeinstellungen ausgeht 192.168.50.1 sein, da der Server auf .1 ist.
Probiere das einfach mal aus (ping eine IP im 46.4.106.152/29 Subnet, wenn das nicht funktioniert poste mal die Server Routen (sollten aber passen). Melde dich, wenn es nicht klappt.

Edit: Dein route in der Server Config hast du denke ich falsch verstanden... OpenVPN-Syntax ? OpenVPN Wiki schau unter route.
Edit2: Asche über mein Haupt, deine push route ist denke ich doch richtig...
 
Zuletzt bearbeitet:
Oben