Lexmark C510n auf Kubuntu BB

SUID:root

Member of Honour
Habe hier einen Lexmark C510n (Farblaser) mit sagenhafter Treiberunterstützung für nahezu jedes OS. Auch für zig Linux-Distris.

Leider gelingt es mir nicht, Kubuntu mit dem Drucker zu vereinen.

Was habe ich bisher gemacht:

Treiber-CD nach Treiben durchwühlt und nur ein rpm-Paket gefunden. Habe dann rpm nachinstalliert um zu merken, dass mir rpm sagt, ich solle alien nehmen um fremdpakete zu installieren.
Also mit apt "alien" nachinstalliert und rpm-paket zu deb konvertiert. Anschließend Paket installiert ohne Fehlermeldung.

Irgendwo in der DOC stand, man sollte dannn noch setup.lexprint ausführen.
Also habe ich das gemacht. Leider folgten dann einige Fehler bei der Abarbeitung des scripts.
Nach diesem Hin und Her beschloss ich mir den Treiber von der Lexmark-Site passend für Debian zu ziehen.
Paket gezogen, installiert, setup.lexprint ausgeführt (diesmal ohne Fehler), alle Defaults bestätigt, Setup complete. CUPS wurde restartet und laut Script ist alles fertig.

In der Druckerverwatung (KDE) sehe ich den Drucker aber nicht.
Gehe ich dann auf "hinzufügen", sehe ich das Gerät am Parallel-Port. Allerdings finde ich keinen passenden Treiber für das Modell. Wähle ich Lexmark aus (im Treibermenu) , finde ich alle möglichen Modelle, nur nicht meinen Drucker.
Natürlich habe ich noch die Option ein File per Hand auszuwählen über "sonstiges" und könnte den Treiber so auswählen. Leider weiß ich nicht, wo um alles in der Welt ich den finde. Unterhalb von /usr/ wurde ein Verzeichnis namens "lexprint" angelegt das zig Unterverzeichnisse und endlos viele Files enthält, allerdings fühle ich mich von der Menge der Files etwas erschlagen.

Aus Mangel an Erfahrung mit Druckern unter Linux bin ich jetzt sehr verwirrt. :)

Kann mir da bitte Jemand helfen?
Danke :)

Gruss

root
 

Voodoo

New member
Ist jetzt nur ein Schuss ins Blaue, aber hast du vielleicht mehr Erfolg, wenn du den Drucker per Webinterface von Cups statt mit KDE einrichtest?
Gehe einfach mal mit einem Browser auf http://localhost:631/ und versuch da mal, einen Drucker hinzuzufügen.
 

petersilie

New member
ein ähnliches prob hatte ich auch mal hast du schon foomatic-tools installiert nur son einfall der mir spontan ins hirn schoss...

Bzw hast du die installationswizard für drucker nicht genommen von kde?

mfg
 

Voodoo

New member
Original von petersilie
ein ähnliches prob hatte ich auch mal hast du schon foomatic-tools installiert nur son einfall der mir spontan ins hirn schoss...
Daran dürfte es nicht liegen, habe vorher schon in der foomatic-DB nachgeschaut und der Drucker ist dort nicht aufgeführt. War aber auch mein erster Gedanke :)
 

SUID:root

Member of Honour
Original von Voodoo
Ist jetzt nur ein Schuss ins Blaue, aber hast du vielleicht mehr Erfolg, wenn du den Drucker per Webinterface von Cups statt mit KDE einrichtest?
Gehe einfach mal mit einem Browser auf http://localhost:631/ und versuch da mal, einen Drucker hinzuzufügen.

Öhm. Gute Idee. Habs grade versucht.
Hat nur zwei Haken.
1. Der Hinweis: Adminitrative Aufgaben sind aus Sicherheitsgründen deaktiviert.
2. Beim Klick auf den Link Einrichtungsaufgaben bekomme ich einen Login für CUPS. Allerdings weiß ich nicht, mit was man sich dort einloggt. Arbeite selbst als root und der rootlogin passt nicht.

Was ich nicht begreife: Wenn der Treiber ordentlich installiert wurde, müsste er doch auch zukünfitg über das Auswahlmenu für Druckermodelle/treiber zu finden sein!? Es gibt auch ein File "Printers.list" das aus dem Paket installiert wurde, in dem ich die passenden binaries zu den passenden Modellen stehen habe. Nur wie kann ich meiner Kiste sagen, es soll den Treiber nehmen?

@petersilie: Doch, ich habe den Wizard von der Druckerverwaltung genommen.
"Drucker hinzufügen" -> "Drucker auswählen"
Doch da finde ich mein Modell trotz bereits installiertem Treiber nicht. Und installiert ist er eben nicht.

Das Webinterface sagt übrigens auch: no printers

Gruss

root
 

TFEAR

New member
lppasswd ist dein freund...

he lppasswd(1) command is used to add, change, or remove accounts from the passwd.md5 file. To add a user to the default system group, type:

lppasswd -a user ENTER
Password: (password) ENTER [password is not echoed]
Password again: (password) ENTER [password is not echoed]

oder http://www.cups.org/doc-1.1/sam.html
 

SUID:root

Member of Honour
Original von TFEAR
lppasswd ist dein freund...

he lppasswd(1) command is used to add, change, or remove accounts from the passwd.md5 file. To add a user to the default system group, type:

lppasswd -a user ENTER
Password: (password) ENTER [password is not echoed]
Password again: (password) ENTER [password is not echoed]

oder http://www.cups.org/doc-1.1/sam.html

Danke. :)
Gesagt getan. Leider bekomme ich jetzt ein "Authentifizierung fehlgeschlagen Möchten Sie es nochmals versuchen?" statt einer neuen Loginbox (wie es bei Falscheingabe normal ist)
Die Daten sind definitv richtig. ;)

Möglicherweise liegt es ja an:
Administrative Befehle sind in der Webbrowser-Schnittstelle aus Sicherheitsgründen deaktiviert. Bitte benutzen Sie den GNOME CUPS Manager (System > Systemverwaltung > Drucker).

Naja, abgesehen davon, dass ich KDE verwende und es da eben nicht geht...
Versuche mal rauszukriegen wo das deaktivert ist. Vielleicht weiß das ja jemand aus dem Kopf oder hat noch weiterführende Ideen.... :)

Gruss

root
 

petersilie

New member
CUPS-Passwort setzen:

"Zusätzlich muss als Benutzer root mit dem Befehl"
lppasswd -g sys -a root

dasCUPS-spezifisches Passwort für den Benutzer root in /etc/cups/passwd.md5 eingetragen.

mfg
 

SUID:root

Member of Honour
Hm. Danke. Aber auch das bringt keine Änderung. Gleiche Effekt, gleiche Meldung. Es ist zum Haare raufen.

Jetzt mach ich grad rtfm (Lexmark) von Anfang an. Irgendwas ist hier oberfaul.
Ich habe hier einen Lexmark-eigenen Gerätemanager für die Drucker. Kann das Modell auswählen, doch beim erstellen der Druckerwarteschlange bekomme ich die Mitteilung "fehlgeschlagen"

Also machte ich das alles über die Konsole, in der Hoffnung die wäre etwas mitteilungsfreudiger:

root@kubuntu:/usr/lexprint/bin# ./lsdevice -l
Device Name : Lex1
Description : Virtuelles Gerät
Device Type : parallel
Connection : /dev/lp0

root@kubuntu:/usr/lexprint/bin# ./mkqueue -d Lex1 -q queue1 -p 10LC510 -l automatic
lpadmin: add-printer (set model) failed: server-error-internal-error
Error: Creating printer queue queue1 failed.

10LC510 ist die Bezeichnung des Druckers laut Ausgabe von ./supported_printers:

Lexmark C510 10LC510 automatic




edit: vielleicht kann hiermit jemand mehr anfangen?

root@kubuntu:/usr/lexprint/bin# ./mkqueue -d Lex1 -q queue1 -p 10LC510 -l automatic -x
Found Printer Type: [ Lexmark C510 10LC510 automatic ]

Step 1: Verify the existance of the virtual device.
---------------------------------------------------
Virtual Device is found.
..Continue..


Step 2: Verify the queue does not already exist.
---------------------------------------------------
Check Queue Status Output
-------------------------
lpstat: Unknown destination "queue1"!
System Queue [ queue1 ] does not exist.
-------------------------
Printer queue [ queue1 ] does not exist.
..Continue..

Now build virtual queue definition
Running:
/usr/lexprint/jre/bin/java -Duser.language=de -Duser.region=DE -Duser.locale=de_DE.UTF-8 -cp /usr/lexprint/etc: /var/spool/lexmark/unix_prt_drivers/.lexprint::/usr/lexprint/lib/main.jar:/usr/lexprint/lib/jdom.jar:/usr/lexpr int/lib/xerces.jar com.lexmark.unix.drivers.jprint.printeroptions.MakeQueue queue1 desc 10LC510 Lex1 automatic
args.length:5
Creating spool directory [ /var/spool/lexmark/unix_prt_drivers/vir_queues/queue1 ].
Creating the virtual queue definition was successful.

Step 3: Create the queue
---------------------------------------------------
lpadmin: add-printer (set model) failed: server-error-internal-error
Creating queue failed.., exit 1
Error: Creating printer queue queue1 failed.
Remove the virtual queue.
root@kubuntu:/usr/lexprint/bin#
 

petersilie

New member
hast du auch nach dem befehl den ich dir gesagt hatte danach cups neugestartet?

z.B. rccups restart oder killall -HUP cupsd bzw /etc/init.d/cupsd restart?

mfg
 

SUID:root

Member of Honour
Original von petersilie
hast du auch nach dem befehl den ich dir gesagt hatte danach cups neugestartet?

z.B. rccups restart oder killall -HUP cupsd bzw /etc/init.d/cupsd restart?

mfg

Ja. Habe ich getan. /etc/init.d/cupsys restart

Eine Frage habe ich aber noch, die mich verwirrt. Erste Punkt vom setup.lexprint-script

This application is a suid root program, which allows the
root user or members of the administrative group to have
administrative privileges. These privileges include adding,
removing, and modifying printer queues.

To set the administrative group, select any valid group that
is listed in /etc/group file.

Enter an administrative group or press <ENTER>
to use the default (bin): root
---------------------------------------------------

Checking your spool directories:

/var/spool/lexmark exists... OK
/var/spool/lexmark/unix_prt_drivers exists... OK
/var/spool/lexmark/unix_prt_drivers/.lexprint exists... OK
/var/spool/lexmark/unix_prt_drivers/.lexprint/props exists... OK
/var/spool/lexmark/unix_prt_drivers/vir_devices exists... OK
/var/spool/lexmark/unix_prt_drivers/vir_queues exists... OK

Setting PDD permissions... Done

Setze ich dort nicht root, funktioniert gar nichts. Bestätige ich die defaults [bin], lasse es also leer, generiere ich noch mehr Fehler.
Das sollte doch stimmen, dort root zu setzen, oder?

Gruss
 

petersilie

New member
Setze ich dort nicht root, funktioniert gar nichts. Bestätige ich die defaults [bin], lasse es also leer, generiere ich noch mehr Fehler.
Dass dürfte normal sein. bzw muss nicht genau auf dein system passend sein lppasswd


Das sollte doch stimmen, dort root zu setzen, oder?
Klar eine administarive gruppe zu der wohl wie bei jedem linux die gruppe root sein sollte, jedoch könntest du nachschauen ob deine gruppe anders heißt die die administarive bildet.

Auch könntest du mal just4fun ne usergruppe angeben :)
 

SUID:root

Member of Honour
Ich habe nur gefragt, weil die defaults alle passsen aber wenn ich dort weiterklicke eben "bin" als wert übernehme, was mir nicht so einleuchtet.
Also root passt schon. :)

Aber bei einem Blick ins group-file fiel mir das hier auf:

lpadmin:x:104:noone

Müsste das nicht root sein? noone ist mein primärer User, der auch über sudo root sein kann. Könnte da der internal error herkommen?

EDIT: ok. bringt auch nix, das zu ändern.

Zwischenzeitlich hatte ich es mal geschafft. Plötzlich war der Drucker vorhanden, allerdings kam der Druckauftrag nie an. Also nochmal entfernt und nun bin ich wieder so weit wie vorher. Es liegt definitv am Queue. Er kann, warum auch immer, keine Warteschlange einrichten.

Und das Webinterface von CUPS haben die Heinis von Ubuntu gesperrt. Werde das jetzt unlocken, nachdem ich die Manual von CUPS bald duchhabe. :(

Gruss
root
 

SUID:root

Member of Honour
Gelöst

So. Mein Drucker geht. :)
Diese netten Menschen, die das Webinterface gesperrt haben haben in der cupsd.conf ein paar Änderungen vorgenommen um alles abzusichern.

Unter anderen haben sie

#User cupsys
#Group lpadmin

auskommentiert und noch ein paar andere Dinge verbogen. Nachdem ich mir erlaubt habe, das Webinterface wieder betriebsbereit zu machen, kann ich auch plötzlich den Drucker einrichten. :D

Jetzt habe ich aber eine weitere Frage:

Der Drucker steht derzeit auf automatisch, d.h. er wählt zwischen PCL und PS.
Die Testseite sieht auch toll aus :)
Ebenso Texte aus OpenOffice. Sogar farbig. :)
Leider kann ich keine Bilder drucken, denn wenn ich das tue, bekomme ich nur seitenweise Code. Hat da nochjemand einen Tip woran das liegen könnte?

Gruss

root
 

petersilie

New member
liegt am treiber es gibt treiber die nur auf text spezialisert sind ich glaube dass sind generic sachen die bilder filtern. Bei den namen kann ich auch falsch liegen. Jedenfalls verhält sich dass so. Bei deinem drucker gibt es doch bestimmt noch mehrer treiber zu wählen unter deiner geräteklasse. Bei meinem hp4 hat es sich damals ähnlichv erhalten.

mfg

ps. freut mich dass du es nun hingebogen bekommen hast, manchmal sind es einfach banale dinge die schließlich zum erfolg führen.

-petersilie
 

SUID:root

Member of Honour
Jopp. Geht jetzt auch. Manchmal lassen sich Dinge nicht nachvollziehen.
Hab den Drucker nochmal entfernt, neu eingerichtet, zu Mittag gegessen und danach gings. :) Lag bestimmt am Essen. :D

Keine Ahnung wieso, aber er geht jetzt einwandfrei. Danke an Euch für die Hilfe.
Hab einiges über CUPS erfahren.

Gruss

root
 
Oben