libc6 anscheinend zerschossen

#1
Sooooooo.....
ich glaube, dass ich mir heute meine lib6c zerschossen habe, nachdem ich meine dist einem upgrade unterziehen wollte -.-

Code:
Vorbereitung zum Entpacken von .../libc6-dev-i386_2.24-3_amd64.deb ...
Entpacken von libc6-dev-i386 (2.24-3) ...
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/libc6-dev-i386_2.24-3_amd64.deb (--unpack):
 Versuch, »/usr/include/bits« zu überschreiben, welches auch in Paket libc6-dev-amd64:i386 2.24-3 ist
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/libc6-dev-i386_2.24-3_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
Ich habe nun schon viiiiiieles versucht.

apt-get -f install
apt-get clean
apt-get update
apt-get upgrade
aptitude dist-upgrade
apt full-upgrade -f
usw usw usw

nach aptitude -f install war das der Auswurf

Code:
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-6-multilib:
 gcc-6-multilib hängt ab von libc6-dev-i386 (>= 2.11); aber:
  Paket libc6-dev-i386 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes gcc-6-multilib (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libsqlite3-0:amd64 (3.14.2-1+b1) wird eingerichtet ...
libsqlite3-0:i386 (3.14.2-1+b1) wird eingerichtet ...
Trigger für man-db (2.7.5-1) werden verarbeitet ...
Trigger für gnome-menus (3.13.3-8) werden verarbeitet ...
google-chrome-stable (54.0.2840.59-1) wird eingerichtet ...
libpython2.7-minimal:amd64 (2.7.12-3+b1) wird eingerichtet ...
libpython2.7-minimal:i386 (2.7.12-3+b1) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von libc6-dev-x32:
 libc6-dev-x32 hängt ab von libc6-dev-i386 (= 2.24-3); aber:
  Paket libc6-dev-i386 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes libc6-dev-x32 (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libpython2.7-stdlib:amd64 (2.7.12-3+b1) wird eingerichtet ...
libpython2.7-stdlib:i386 (2.7.12-3+b1) wird eingerichtet ...
python2.7-minimal (2.7.12-3+b1) wird eingerichtet ...
libpython3.5-minimal:amd64 (3.5.2-6+b1) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von g++-6-multilib:
 g++-6-multilib hängt ab von gcc-6-multilib (= 6.1.1-11); aber:
  Paket gcc-6-multilib ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes g++-6-multilib (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
libpython3.5-stdlib:amd64 (3.5.2-6+b1) wird eingerichtet ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von gcc-multilib:
 gcc-multilib hängt ab von gcc-6-multilib (>= 6.1.1-9~); aber:
  Paket gcc-6-multilib ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes gcc-multilib (--configure):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
python2.7 (2.7.12-3+b1) wird eingerichtet ...
sqlite3 (3.14.2-1+b1) wird eingerichtet ...
python3.5-minimal (3.5.2-6+b1) wird eingerichtet ...
libpython2.7:amd64 (2.7.12-3+b1) wird eingerichtet ...
libpython2.7:i386 (2.7.12-3+b1) wird eingerichtet ...
libpython2.7-dev:amd64 (2.7.12-3+b1) wird eingerichtet ...
python2.7-dev (2.7.12-3+b1) wird eingerichtet ...
python3.5 (3.5.2-6+b1) wird eingerichtet ...
libpython3.5:amd64 (3.5.2-6+b1) wird eingerichtet ...
Trigger für vlc-nox (2.2.4-6+b2) werden verarbeitet ...
Trigger für libc-bin (2.24-3) werden verarbeitet ...
Trigger für menu (2.1.47) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 gcc-6-multilib
 libc6-dev-x32
 g++-6-multilib
 gcc-multilib
Also ist das Grundproblem die libc6-dev-i386, die nicht installiert werden kann^^

Immer wieder wird mir die libc6-dev-i386_2.24-3_amd64.deb als Fehler ausgeworfen. Ich gehe davon aus, dass die Abhängigkeiten einen wegbekommen haben.
Aber in /usr/inculde/bits oder /car/cache/apt/archives/ finde ich nichts was mir weiterhilft um die Fehler zu beheben.

Habt ihr eine Idee, oder muss ich das System neu aufsetzen und hoffen, dass das nächste upgrade funktioniert?

Aufgefallen ist es mir dann als ich den Nvidea Treiber installieren wollte, um die Cuda Pentest Tools zu nutzen, und schon
apt-get install -y linux-headers-$(uname -r) nicht funktioniert hat.

-edit-

Code:
Die folgenden Pakete haben unerfüllte Abhängigkeiten:
 g++-6-multilib : Hängt ab von: gcc-6-multilib (= 6.1.1-11) soll aber nicht installiert werden
 libc6-dev-x32 : Hängt ab von: libc6-dev-i386 (= 2.24-3) soll aber nicht installiert werden
Das ist nur ein Ausschnitt. Habe auch versucht die Abhängigen Pakete zu installieren, jedoch sind die alle voneinander abhängig, so dass dies auch nicht funktioniert hat.
 
Zuletzt bearbeitet:
#2
Ich habs jetzt nur überflogen und denke du hast nur ein Architektur-Problem. Sonst schau ich die Tage mal genau drüber oder jemand kommt mir zuvor [emoji1]

Nebenbei ist mir kein aptitude reinstall aufgefallen [emoji12] alles versucht.... ja ja [emoji38]

Multiarch/HOWTO - Debian Wiki
 

SchwarzeBeere

Moderator
Mitarbeiter
#4
Die Fehlermeldung ist doch relativ klar:

Bei der Installation des Pakets libc6-dev-i386_2.24-3_amd64.deb kommt die Fehlermeldung:
Versuch, »/usr/include/bits« zu überschreiben, welches auch in Paket libc6-dev-amd64:i386 2.24-3 ist
Paketname in fett, Architektur in rekursiv.

Die Lösung ist wohl, dass du nur eine Version der Library installierst, vorzugsweise die, die du auch benötigst. Die andere entfernst du mit "dpkg --purge --force-depends ...".

Alternativ - mangels Wissen zu aptitute kann ich das nicht bestätigen - soll wohl auch das hier funktionieren: aptitude install libc6-dev:i386

Quelle:
Für Ubuntu gibt es einen entsprechenden Bug-Report, bislang ohne offizielle Lösung: Bug #1365375 “package libc6-dev-i386 (not installed) failed to i...” : Bugs : eglibc package : Ubuntu
 
Zuletzt bearbeitet:
#5
Hatte ich schon versucht, aber selbst beim entfernen, verweist er auf die fehlenden Abhängigkeiten und es lässt sich nicht entfernen.
Auch die Installation des Pakets funktionierte nicht :)
 
#6
auch mit clean vorher?

apt-get clean
apt-get purge libc6-dings:i386
dpkg --add-architecture i386
apt-get update
apt-get install libc6-dings:i386

Bei purge evtl nochmal genau hinschauen, dass das richtige Paket entfernt wird.
 
Zuletzt bearbeitet:
#8
Habe das alles schon im Vorfeld versucht.
Hatte alles keinen Erfolg.

System nun neu aufgesetzt. Lief jetzt alles Problemlos durch. Schön das man regelmäßig alles sichert und auch Images macht.
Danke aber für eure Hilfe.
 
Oben