Merkwürdige ereignisse mit SSH-Tunnel u. Socks

Dr.Hero

New member
Hab folgendes Problemm und zwar wenn ich mein Traffic durch den
SSH-Tunel und/oder Proxey laufen lassen werden bei Google die Suchanfrage
garnicht geladen und man muss auf den Button (Firefox) "Aktuelle Seite neu laden"
drücken, erst danach lädt er die Suchanfrage. (Siehe Pic)

Oder mal ein anderes Beispiel: es werden auch keine Youtube Vidoes mehr angezeigt (Siehe Pic)

Aber das ist noch nicht alles, denn wenn ich den Kaspersky Internet Security anschmeiße läuft
alles wieder einwandfrei.

Es kann nicht an Vieren liegen den ich habe meine Festplatte komplett mit DBAN löschen lassen.

Weiß echt nicht woran es liegen könnte, wäre echt glücklich wenn mir jemand was dazu sagen könnte.

Edit: Bilder konnte ich auch nicht mit SSH-Tunel oder mit dem Socks hochladen. Sind jetzt aber dazugefügt wurden
 

bitmuncher

Senior-Nerd
Treten die Problem auch bei Verbindungen auf, die nicht SSL-gesichert sind? Was sagt ein HTTP-Trace zur Antwort des Servers auf die Requests deines Browsers? Kommen gar keine Antworten durch oder ggf. Fehler-Stati vom Server? Hast du im Browser evtl. irgendwelche Kaspersky-Plugins, die einfach keinen Response von ihrer API bekommen? Wie sieht der TCP-Stream aus; gibt's Paketverluste? Kurzum: Versuch so viele Informationen zu dem Problem zu sammeln wie du kannst.
 

Brabax

New member
wenn ich mein Traffic durch den SSH-Tunel und/oder Proxey laufen lasse

Wie richtest du denn bei dir den Proxy ein?
Was für ein Proxy ist das?

Ich denke eher an ein Dritt-Server-Problem.
Also im Sinne von:

[DU] <---> [Proxy-Server] <----> [Google-Server] ----> [Ajax-Request-Server] ---- [...]

Wenn die Queries in der Suchbox über sonstwelche Javascripts an einen Dritt-Server gesendet werden, __könnte__ es gut sein, dass die Rückstrecke nicht mehr funktioniert.
Wenn du Google mal mit Firebug->Netzwerk untersuchst, tauchen dann Übertragungsfehler auf?
 

Dr.Hero

New member
So ich habe mal auf seiten rumgesurft die nicht SSL gesichert sind. Und ich konnte keine Probleme feststellen.

So dann muss ich sagen das ich mich mit den Netzwerken nicht so gut auskenne.
Aber das macht nichts denn man kann alles nachlesen und lernen macht ja den Meister.
Also habe ich mich mal umgeschaut wie ich den Http-trace durchführen soll und bin auf folgendes Tool gestoßen: HTTP Analyzer V7
So wie ich das verstehe ist der Analyzer auch für die Untersuchung der Paket verluste geeignet.
Das gilt auch für Firebug->Netzwerk da habe ich Firebug gefunden.

Bin ich da auf dem richtigen Weg mit den Tools???

Ja ich habe einen Anti-Banner Addon von Kaspersky.

Der Anbieter der Proxys ist Perfect-Privacy.
Die Verbindung wird folgendermaßen erstellt:
Vpn > SSH-Client > Proxifer für Socks5.
Die Clients sind natürlich alle von Perfect-Privacy.




 

bitmuncher

Senior-Nerd
Mit Firebug wirst du die wichtigsten Infos bekommen. Interessant ist ja erstmal ob du vom Webserver eine Antwort bekommst und wenn ja welche.
 
Oben