Nas Datenrate im Netzwerk langsam

ghostdog

Active member
#1
Hi Habo

Wenn NAS und Rechner an einem Switch hängen (und sonst nichts) wird übertragen mit 30MB/s, hängt man noch das Heimnetzwerk, also den Router in den Switch werden daraus 100-250kb/s. Der Router sollte allerdings nicht das Bottleneck sein, da zwischen je zwei Rechnern die Kommunikation (z.B. Windows Dateidienst) sehr schnell läuft, nur zwischen NAS und Rechnern nicht.

Ich versuche zu erörtern woran es liegen kann, habe leider nicht zuviel Erfahrung/Wissen was Netzwerke angeht.
 
#2
Was sagt den die Netzwerkkonfiguration von den 3 Netzwerkkarten?

Von deiner Beschreibung her liegt es nahe das die Konfiguration das ausbremst.


Ich hatte das mal das ein Router und ein LinuxPC die gleiche IP in einem Netzwerk hatte.
Lief aber nicht sehr schön, aber Windows hat, zu recht, gestreikt, ist auch nur so aufgefallen :D .

Handlet es sich wirklich nur um eine switch oder kann die Schnittstelle ggf. mehr, zB vlans, etc....
Gruß

Fluffy
 

ghostdog

Active member
#5
Ohne Switch (also sowohl NAS als auch nen PC in den Router und dann kommunizieren) ist dasselbe Problem. Die Netzwerkkonfiguration checke ich mal, wenn ich zu Hause bin.

Falls jeder seine eigene IP hat, was könnte dann noch möglich sein?
 
#6
Vielleicht ist der Router ja der 10 Mbit Flaschenhals und zwingt das Switch auf 10 MBit zu schalten. Das Patchkabel könnte auch ein Störfaktor sein, warum keine 100 MBit zustande kommen.
Welches Switch,NAS,Router nutzt du denn?
 

ghostdog

Active member
#7
Vielleicht ist der Router ja der 10 Mbit Flaschenhals und zwingt das Switch auf 10 MBit zu schalten. Das Patchkabel könnte auch ein Störfaktor sein, warum keine 100 MBit zustande kommen.
Welches Switch,NAS,Router nutzt du denn?
Der Router alleine scheidet leider aus, da 2 PCs in den Switch und dann in den Router beliebig schnell sind. Der Switch scheidet auch aus, weil NAS und PC in den Router auch auf höchstens 300kb/s kommt. Offenbar mögen sich NAS und Router nicht.

Die Kabel habe ich alle mal ausgetauscht, selbes Problem.

Router ist ein Alcatel-Lucent Router des Glasfaseranbieters (gemietet), leider intransparent und kein Zugang gestattet seitens des Benutzers. NAS ist ein Synology ds215j. Lief früher übrigens alles mal reibungslos, das ist eine neue Entwicklung.

Im Übrigen wäre ich mit 10 Mbit vollkommen zufrieden, auch wenn das nicht das Optimum ist. Nur 300 kb/s geht gar nicht.
 
#11
Der Switch war wie bereits erwähnt nie das Problem, sondern ein Testtool und kein fester Bestandteil des Netzwerkes. Auch wenn ich mir wünschen würde, dass der Switch das Problem wäre :(

Habe nochmal die Netzwerkkonfiguration geprüft, so wie das Netzwerk normal aussieht. Jeder hat seine eigene IP (NAS, alle PCs), Kommunikation zwischen NAS und PCs ist langsam (<300kb/s), Kommunikation zwischen PCs ist normal (30-140MB/s). Auch wenn alle direkt im Router hängen.
 

SchwarzeBeere

Moderator
Mitarbeiter
#13
Schon mal mit Wireshark oder tcpdump den Netzwerkverkehr angeschaut? Broadcasts, Multicasts und Co, z.B. im Rahmen des NDP, können u.U. die Verbindung stark belasten. Auch wäre es interessant zu sehen, welche Pakete in dem Moment ausgetauscht werden, wenn du das Kabel in den Port steckst.
 
#14
Ich würde das Analysieren einstellen, da der nicht konfigurierbare Router die Ursache zu sein scheint ;) die günstigste und schnellste Lösung ist das Gerät zu trennen :)
 

SchwarzeBeere

Moderator
Mitarbeiter
#15
Dem widerspreche ich. Gerade im Fall von NDP löst z.B. das Abstellen von IPv6 das Problem. Außerdem wäre ein Bug direkter Grund, den Router durch den Hersteller austauschen zu lassen. Und der Aufwand dafür hält sich in Grenzen...
 
#16
Hmm ich glaub der Aufwand is schon jetzt mehr als ein 20 € Router kosten würde. Aber ok.

Warum glaubst du, dass das NDP nur den Verkehr zwischen PC und NAS beeinträchtigt und die Kommunikation zwischen PC zu PC problemlos funktioniert?

Ist eigentlich das Up-/Downloadverhalten gleich?
 
Zuletzt bearbeitet:

SchwarzeBeere

Moderator
Mitarbeiter
#17
Siehe Wikipedia:
Router versenden in gewissen Zeitabständen Router-Advertisement-Nachrichten per Multicast. Die Informationen in diesen Nachrichten werden verwendet, um die Default Router List und die Prefix List zu erstellen. Nach Ablauf der angegebenen Lebenszeit werden die Einträge wieder aus den Listen gelöscht. Dadurch bleiben nur Router eingetragen, die aktiv sind und ihre Anwesenheit periodisch kundtun. Um nicht auf das nächste geplante Router Advertisement warten zu müssen, kann ein Knoten per Router-Solicitation-Nachricht an die Router-Multicast-Adresse ein Router Advertisement erzwingen. Dies ist besonders beim Aktivieren eines neuen Interfaces von Vorteil, um mit der Konfiguration nicht warten zu müssen.
In buggy Environments endet das nicht selten in einem "Packet Storm" zwischen Client und Router. Und wenn dann noch mehrere Clients involviert sind oder ein Angreifer das ausnützen wöllte...
 
Zuletzt bearbeitet:

SchwarzeBeere

Moderator
Mitarbeiter
#19
Es war nur ein Beispiel für einen Bug, mit dem ich selbst schon zu kämpfen hatten. Die allgemeine Aussage ist, dass der Netzwerktraffic üblicherweise bei Netzwerkprobleme sehr viele Informationen liefern kann ;)
 
Oben