NFS auf ipfire und chmod-rechte

citizenfive

Stammuser
Hallo!
Ich habe ein Problem Schreib- und Leserechte für ein NFS-Laufwerk zu erteilen.
fstab soweit bearbeitet
"ipfire-IP:/nfs-server-Ordner /lokaler-Ordner des Clients nfs user,rw,noexec,nofail,sync,rsize=8192,wsize=8192 0 0"
und gemountet. Funtioniert mit user wunderbar, nur ohne Schreibrechte.

Das Problem ist wohl, dass der Client-Ordner in dem ich den NFS-Ordner mounte gehört dem user, wenn er aber dorthin gemountet wird, gehört er dem root.
Kann ich nicht nachvollziehen.

Jemand eine Idee?
Danke schon mal!
c5
 

bitmuncher

Moderator
uid und gid als Mount-Parameter könnten evtl. helfen. Hab aber gerade nicht im Kopf, ob das mit NFS-Mounts funktioniert. Versuch macht klug. ;)
 

citizenfive

Stammuser
hmmm, das wäre ja super. An welcher Stelle füge ich allerdings die uid und gid hinzu?
Wenn ich die irgendwo in den Optionen anhänge, gibt er mir einen Fehler beim Mounten aus und redet von incorrect mount option.
Das ist jetzt z.B. eine Option gewesen:
user,rw,noexec,nofail,sync,rsize=8192,wsize=8192,uid=1000,gid=1000 0 0
 

citizenfive

Stammuser
hab auch bei meiner Windoofs-Machine ein PSDrive eingerichtet, aber auch da keine Schreibrechte...
wenn ich die NFS-Attribute beim gemounteten Server-Ordner im Windoofs ändern will, geht es nicht mal mit dem Admin-account. Irgendwie komm ich da ganz schön an meine Grenze der Kenntnisse :D
 
Zuletzt bearbeitet:

citizenfive

Stammuser
Die Rechte des gemounteten Ordners auf dem Client, demnach auch die Rechte des Ordners auf dem Server:
drwxr-xr-x 8 root root 16K Jan 1 1970 /xxx/server
Die Rechte des unmounteten also lokalen Ordners in den gemountet wird:
drwx------ 2 user user 4.0K Jun 28 20:56 /xxx/server

Wie es aussieht, muss ich die Rechte auf dem Server so ändern, dass sie auf den jeweiligen lokalen User übertragen werden. Nur wie??

Muss ich bei dem Server-Ordner den chown user /xxx/server und chgrp user /xxx/server machen?
Obwohl "user" gibt es gar nicht als Benutzer auf dem Server. Soll ich dann chwon und chgrp auf users setzen?
Wobei es ja irgendwie um einen anonuser gehen sollte.

Kann es auch mit der /etc/exports auf dem Server zu tun haben?
Dort habe ich folgende Optionen für entsprechende Clients:
(rw,async,subtree_check)
habe "no_root_squash,anonuid=99,anongid=99" zu den jeweiligen Clients hinzugefügt und den NFS-Server neu gestartet.

Windoofs über LAN funktioniert nach diesen Änderungen in exports auf dem Server (wobei lediglich der Eintrag no_root_squash Schreibrechte gewährt). Linux-Laptop will auch über LAN weiterhin keine Schreibgenehmigung bekommen.

mit den anongid und anonuid kenne ich mich gar nicht aus, vermutlich muss ich bei Linux irgendwie etwas mit den uid gid einstellen. In fstab klappt es allerdings nicht, also vermutlich muss etwas in exports extra eingestellt werden.

moun -v auf dem Linux-Client (bei gemounteter Platte) zeigt mit, dass es in rw gemountet ist, hää??
 
Zuletzt bearbeitet:

schwedenmann

Stammuser
Hallo

1. welche nfs-version benutzt du ?
Sollte nfsv4 sein

2. ich würde mal eine user test und user keintest auf dem Cleint und dem Server anlegen, mit jeweils derselben UID !

3. Als exportiertendes verzeichnis des server z.B. /srv/nfsv4 erstellen und Dateirechte auf 777 setzen (nur testweise, wenns ein lokale nett ist, ist das eh egal)

4. Auf dem Client auch ein Verzeichnis anlegen z.B. /nfsshare und auch die rechte auf 777 setzen
5.auf dem Cleint dann
mount -t nfs4 serverip) z.B. 192.168.178.100:/srv/nfsv4 /nfsshare

6. Auf dem Client dann als user test eine Datei kopieren nach /nfsshare und auf dem Client eine datei als user test per touch /nfssahre/testdatei.txt anlegen. selbiges mit user "keintest" machen und dann auf dem cleint und dem server die Dateirechte kontrollieren.

7. exports sollte so aussehen, reicht für tests:
192.168.178.0/24(rw,fsid=0,insecure,no_subtree_check,async)

mfg
schwedenmann

P.S.
IP und dateipfade müsen nat. angepaßt werden, bzw. können frei gewählt werden.
da ich kein Konsoenjunky bin, mache ich chown und chmod per mc
 

citizenfive

Stammuser
laut mount -v ist es die nfs4

die Rechte auf dem Server habe ich für das Verzeichnis bereits auf 777 gesetzt

auf dem Client habe ich das Verzeichnis ins home übertragen und dort 777 gesetzt

wenn ich als user mount - t etc. ausführe, dann sagt er mir, dass nur root --types option nutzen kann. Beim mounten als root, kann ich als user nicht schreiben.

exports habe ich für einzelne IPs freigegeben
Warum no_subtree_check? Ich nutze nur einen Ordner auf dem Server und nicht den gesamten Baum
insecure und fsid=0 kenne ich nicht.
Habe die Optionen bei exports ausprobiert, immernoch kein rw für user.

Als vorhandener User kann ich nicht dorthin kopieren, auch nicht per touch erstellen.

Habe jetzt auf dem Server und auf dem Client user "test" erstellt und GID und UID auf gleiche Zahl gesetzt.
Wie kann ich aber als bestimmter user Dateien erstellen per Teminal?
 

schwedenmann

Stammuser
Hallo

Wie kann ich aber als bestimmter user Dateien erstellen per Teminal?
log dich als user test ein und dann per touch eien Datei anlegen.
dann exit
dann wieder login deinuser
touch neuedatei

exit

mfg
schwedenmann

bei mir klappt das mit den obigeb Einstellune, beides debian-PC server und Client, nfsv4 wird benutzt. Beide user exietieren auf dem Client, wie auf dem srver und haben dieselbe UID = 1000

 

citizenfive

Stammuser
das ist glaub bei QubesOS nicht ganz so einfach mit den Usern, vermute ich, obwohl es eigentlich gehen sollte.
Wenn ich login test eingebe kommt zwar kein Fehler, ich bin aber nicht als test eingelogt.

Im Prinzip kann ich ja vom aktuellen user die UID und GID ändern und an die auf dem Server anpassen (müssen sie gleiche Benutzernamen haben oder nur gleiche UID und GID?) Das Problem ist nur, dass ich dafür vom account ausgeloggt sein muss, um die UID und GID zu ändern.

Und kann es zu Problemen führen, wenn ich die UID und GID des Normalusers ändere. Bisher habe ich ja so dezidiert nichts angepasst.
 
Zuletzt bearbeitet:
Oben