opensuse leap 15.0 bleibt an/etc/fstab hängen

WGz

Member
Hallo,
ich hatte in /etc/fstab wohl etwas stehen, das falsch war.
Ich habe das aber alles wieder mit opensuse Leap 15.0
Rescue-Live korrigiert. Dennoch bleibt das Booten hängen.
Das hatte ich bei früheren Versionen nicht.

Was muss ich machen, damit das /etc/fstab anerkannt
wird?

Übrigens das fstab.YaST2.save habe ich auch bereinigt!

Danke für rettende Hilfe,
Werner
 

kaputtnik

Stammuser
Pauschal würde ich erst mal sagen, dass du noch nen Fehler in der fstab übersehen hast, sonst würde das System dort nicht hängen bleiben.

Um dir aber wirklich helfen zu können, wären schon ein paar mehr Infos nötig. Bei welcher Meldung bleibt dein System denn hängen und wie sehen die fstab und die Festplattenkonfiguration aus?
 

WGz

Member
Danke für die rasche Antwort.
Hier mein derzeitiges knappes /etc/fstab:
UUID=67854c0e-82f6-4580-83eb-10e7ab13c9d8 swap swap defaults 0 0
UUID=484bd7cb-9384-4e56-9076-f8d7ac69d6cb / xfs defaults 0 0
UUID=649e9c05-51a0-44db-a454-df505d8cde18 /home xfs defaults 0 0
UUID=C6E6-AF43 /boot/efi vfat defaults 0 0
UUID=9713be20-9dd0-4aac-8cd5-97c56121ced8 /ARCHIV ext4 defaults 0 0
Dies ging bisher ohne Probleme!

Meldung bekomme ich keine. Es steht oben rechts ein blinkender Cursor, sonst nichts.
Bemerkenswert ist, dass, obwohl ich die Verbindungen zu windows gelöscht habe,
diese alle C, D, und E im Rescue-Live dennoch erscheinen. D.h. doch wohl, dass der
PC irgendwo im Hintergrund die kaputte fstab noch gespeichert hat. Das macht wohl das
openSUSE Leap 15.0

Hat das bei Leap 15.0 wieder was mit systemctl zu tun?
 

WGz

Member
Hier noch meine Festplatten:

/dev/sdb1 fat32 10.00 GB boot,esp (boot,esp)
/dev/sdb2 linux-swap 10.00 GB swap
/dev/sdb3 xfs 200.00 GB legacy_boot ( / )
/dev/sdb4 xfs 711.51 GB legacy_boot (home)
In /dev/sda1 liegt windows/C:
in /dev/sda2 liegt ??? (diag,type)
in /dev/sda3 liegt windows/D:
in /dev/sda4 liegt windows/E

In /dev/sdc1 liegt archiv
 

WGz

Member
Ich habe
/dev/sdb1 (boot,esp) in Rescue-Live gemountet an /mnt
/deb/sdb3 ( / ) in Rescue-Live gemountet an /mnt2
In /mnt/ ist nichts
in /mnt2/ ist das volle boot

M.E. müsste doch in /mnt/ das ganze boot stehen.
 

WGz

Member
Es war ein Problem mit dem UEFI, das mein BIOS nicht kann.
Ich habe openSUSE Leap 15.0 völlig neu ohne UEFI installiert.
Nun funktioniert alles wieder.
 
Oben