Samba @ Fedora8

bikmaek

Member
Wunderschönen guten Abend,

mal wieder ein kleines Problemchen:

Mein Server (Fedora 8 - aktuelle Updates) macht seine Freigaben nicht so wie ich das will.

Auf die Freigaben kann ich zugreifen wie ich das Rechtemäßig erlaubt habe, aber wehe ich mounte in den Freigaben eine Festplatte - dann geht nichts mehr. (siehe Bild).

So langsam weiß ich echt nicht mehr weiter.

Vllt. jemand einen Tipp???

mfg bikky
 

bikmaek

Member
Code:
[global]

        workgroup = blubber

        server string = fc-00

        cups options = raw

        log file = /var/log/samba/%m.log
        max log size = 50

        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

        os level = 128
        preferred master = yes
        wins support = yes
        dns proxy = no
        idmap uid = 16777216-33554431
        idmap gid = 16777216-33554431
        template shell = /bin/false
        winbind use default domain = no
        username map = /etc/samba/smbusers


[freigabe1]
        path = /mnt/freigabe1
        writeable = yes
        browseable = yes
        valid group = privat, safe
        write list = bikmaek

[freigabe2]
        path = /mnt/freigabe2
        writeable = yes
        browseable = yes
        valid group = privat, safe, share
        write list = bikmaek
dabei sei zu sagen, dass die o.g. smb.conf einwandfrei unter FedoraCore 5 gelaufen ist.

mfg
 

bikmaek

Member
wie ich mounte?

ääh nicht dein ernst oder? ich kenne zwar mehrere wege aber hier meinen üblichen:
Code:
[root@fc-00 ~]# mount /dev/mapper/freigabe1 /mnt/freigabe1
vorher mache ich noch ein schönes
Code:
[root@fc-00 ~]# cryptsetup create freigabe1 /dev/sdb1
und tippe meine passphrase da ein.

alle dateien auf der hdd gehören "bikmaek" und der gruppe "safe". Damit sollte ich vollen Zugriff auf die Daten haben.

Wie gesagt: Mit meiner "alten" FedoraCore 5 hat das alles geklappt.

p.s. wie ich gerade festgestellt habe, komme ich nur in freigaben rein, die leer sind. wenn da schon "Sachen" drin sind, bekomme ich auch o.g. Meldung. Wenn ich aber nachdem die Freigabe da ist, Ordner erstelle - geht alles -> komisch komisch

Langsam aber sicher zweifel ich an mir selbst :)

mfg
 

naked_chef

New member
Original von bikmaek
alle dateien auf der hdd gehören "bikmaek" und der gruppe "safe". Damit sollte ich vollen Zugriff auf die Daten haben.
und wem gehört das Verzeichnis in das gemountet wird? in diesm fall freigabe1 ...
wie sind dort die rechte gesetzt?
 

bikmaek

Member
die gehören jetzt auch "bikmaek" und "safe".

Nach vielen reboot's von Client und Server und ein paar versuchen nun diese Meldung: (siehe Bild)

Ist das ein Müll.

mfg bikky

edit: wenn ich das laufwerk "umounte" dann geht wieder alles ...
 

naked_chef

New member
versuche mal bitte unter "freigabe1" einen ordner anzulegen, z.B. test.
und mounte deine platte nach test.
versuche dich mit der freigabe zu verbinden und auf test zuzugreifen.
 

bikmaek

Member
also hab das mal gemacht, und siehe da der Ordner "test" verschwindet sobald ich die hdd da mounte.

gibt schon sachen die gibt es nicht (das mal paradox :) )

mfg
 

naked_chef

New member
wohin mountest du? nach test oder freigabe?
wenn du nach freigabe mountest, ist klar das test verschwindet ...
wenn du nach test mountest und es verschwindet dann, dann hast du ein Problem mit dem system und nicht mit samba ...
 
Oben