[Fritz!BoxFon + WRT54GL + einf. FritzBox] Problem mit Internet-Telefonie

beavisbee

Member of Honour
Hallo,

hab bei meiner Schwester folgendes Problem:
bisher hatte sie 'ne relativ einfache FritzBox SL WLAN ("FB") und 'ne FritzBoxFon WLAN 7170 ("FBF WL") oder so...

die einfache FB hatte die DSL-Zugangsdaten und war als Basisstation für Repeater-Betrieb (WDS) konfiguriert.

die "FBF WL" war (und ist auch noch) eine Etage höher und da hängt das Telefon dran, mit welchem sie i.d.R. über Internet-Telefonie telefoniert.
Zusätzlich hängt die FBF WL noch an einem weitergeführten TAE-Anschluss, um auch Festnetz-Telefonate entgegen nehmen zu können.

Problem war bisher: dicke Wände etc. --> WLAN-Verbindung zwischen den 2 FB's zu schwach --> wenn Verbindung unterbrochen, im 1. OG kein Internet mehr und raustelefoniert wurde ungewollt über Festnetz.

Daher hab ich jetzt meinen WRT54GL (Firmware: aktuelles Tomato - v1.27.1798 ) noch dazwischen geschalten (da bessere Antennen und höhere Sendeleistung möglich)

Siehe Bild im Anhang!


Die einfache FB läuft jetzt als reines Modem (PPPoE), WLAN deaktiviert, "DSL-Filter" ebenfalls deaktiviert, WRT54GL wählt sich ins Netz ein (WAN-Type=PPPoE) und FBF WL baut Repeater-Verbindung (WDS) mit WRT54GL auf.

(WirelessMode im WRT54GL: reines WDS)


Internet läuft einwandfrei - vorher wurde die Verbindung zur Basisstation (FB) immer auf 1MBit gedrosselt, um überhaupt noch was aus dem Rauschen raus zu bekommen, jetzt läuft die Verbindung mit 36 MBit stabil...

Nur leider geht jetzt die Internet-Telefonie gar nicht mehr...

Einstellungen am WRT54GL:

Code:
Firewall:
=========
Respond to ICMP ping    X
Allow multicast         X
NAT loopback            ALL
Enable SYN cookies      X

(also erstmal alles erlaubt, was nur irgendwie ging)



Port-Forwarting:
================

On    UDP        5060               192.168.178.1
On    UDP        3478               192.168.178.1
On    UDP        3479               192.168.178.1
On    Both       16384-16400        192.168.178.1

(192.168.178.1 = FBF WL)



Enable UPnP       X
Enable NAT-PMP    X
 

throjan

Administrator
Mitarbeiter
Du hast den RTP-Stream vergessen :wink: Stell doch mal das Portforwarding für die Ports 5004 - 65535 ein. Alternativ kannste auch vorher mal mit Wireshark ein SIP-Trace durchführen.
 

beavisbee

Member of Honour
thx. wenn ich mal wieder dort bin, probier ich das vielleicht mal aus, einfach, um zu sehen, ob's dann geht...

hab, da es gestern abend noch laufen sollte, das dann so geändert:

"FBF WL" nach unten, dort Multi-Drucker-Fax-Fon-Dingens ran gehängt und die Strippe, die dann an die hochgezogene TAE geht (hatte glücklicherweise gleich zu Anfangs mal die Idee, das Kabel aus der 1. TAE raus zu nehmen und ein Stecker ran zu löten - somit hängt die obere TAE jetzt an der Fritzbox unten...)

Hab dann die kleinere Fritz!Box oben in's Wohnzimmer und meinen WRT54GL ins Zimmer nebenan (direkt über dem Büro) als reinen WDS, welcher WEP-verschlüsselt zwischen den 2 FB's vermittelt (die FB's können bei WDS nur entweder offen, WEP oder WPA2 - und der WRT kann nur offen, WEP oder WPA1 ...)

die WEP-Verbindung ist, da er als reiner WDS läuft, nicht mehr aufspürbar und nicht mehr drauf zugreifbar und zusätzlich noch MAC-Filter, der nur die 2 FB's drauf lässt und bei den Geräten, die überhaupt über WDS kommunizieren dürfen, sind auch nur die 2 FB's angegeben... sollte, hoffe ich, soweit sicher sein, oder?


wenn das jetzt zu verwirrend war:
Code:
[Tel @Wohnung]                      ----> [WRT54GL] <------WDS(WEP)------>[FB @Wohnzimmer]<----AP(WPA2)----->[PCs]
         |                         /
         |                        /
         |                       /
         |                      /
         |                     |
[FBF WL @Büro] <------WDS(WEP)--
    |  |    \  \
    |  |     \  \
    |  |      \  \
tel |  | dsl   |  \---[PC@Büro]
[Splitter]     |
   |       [Fax/Tel@Büro]
[1.TAE]
 
Oben