Mailversand vom eigenen Mailserver: No SMTP service 554-Bad DNS PTR resource record

overflow

Member of Honour
Hallo zusammen,

mein eigener Mailserver steht nun seit einigen Wochen.

Ich habe vor kurzem bemerkt, dass Mails bei GMX und WEB.DE nicht ankommen.

Fehlermeldung sieht wie folgt aus:

Mar 26 09:36:41 mail postfix/smtp[28451]: B6C921F1F4: to=<XXXXXXXXXX@gmx.de>, relay=mx01.emig.gmx.net[212.227.17.5]:25, delay=377, delays=377/0.1/0.08/0, dsn=4.0.0, status=deferred (host mx01.emig.gmx.net[212.227.17.5] refused to talk to me: 554-gmx.net (mxgmx117) Nemesis ESMTP Service not available 554-No SMTP service 554-Bad DNS PTR resource record. 554 For explanation visit https://www.gmx.net/mail/senderguidelines?ip=172.105.94.46&c=rdns)

Mein Setup auf der Lineode Cloud

Unter der URI domain.tld ist meine Plattform erreichbar. E-Mails werden über ein Relayhost (mail.domain.tld) verschickt.
Web- und Mailserver-Dienste sind dabei (logischerweise) auf unterschiedlichen Servern.

Mein SPF Record baut sich folgendermaßen auf.
v=spf1 a mx ip4:10.20.30.40 a:mail.domain.tld -all

DMARC sieht dann so aus:
v=DMARC1; p=reject; rua=mailto:postmaster@domain.tld; ruf=mailto:postmaster@domain.tld; sp=reject; aspf=s; fo=0;

Mein RDNS habe ich nach diesem Schema aufgebaut:
40.30.20.10.in-addr.arpa

Jemand 'ne Idee???...
 

overflow

Member of Honour
Gelöst:

RDNS abgelöst durch in-addr.arpa und ersetzt durch mail.domain.tld

Mail kommt an und landet im SPAM, aber das kriege ich wohl gelöst :)
 
Gelöst:

RDNS abgelöst durch in-addr.arpa und ersetzt durch mail.domain.tld

Mail kommt an und landet im SPAM, aber das kriege ich wohl gelöst :)
Schon das Problem gelöst, dass deine Mails im Spam Ordner landen?

Bei meinen Mailserver (OpenBSD+OpenSMTPd) trifft es noch gelegentlich noch zu. Hatte vorher das Problem bei allen Mails. Bin mir nach wie vor noch nicht sicher, was jetzt die Mails als Spam klassifiziert.
 

overflow

Member of Honour
Bis auf Outlook/Hotmail und Konsorten kommt inzwischen alles an.
Bekomme immer die Meldung:

host eur.olc.protection.outlook.com[XXX.XXX.XXX.XXX] said:

550 5.7.1 Unfortunately, messages from [XXX.XXX.XXX.XXX] weren't sent. Please contact your Internet service provider since part of their network is on our block list (S3140). You can also refer your provider to http://mail.live.com/mail/troubleshooting.aspx#errors.
[VI1EUR06FT005.eop-eur06.prod.protection.outlook.com] (in reply to MAIL FROM command)

Als SPF Record habe ich folgendes gesetzt:
v=spf1 a mx ip4:MEINE_SERVER_IP a:mail.domain.com -all
 
...your Internet service provider since part of their network is on our block list (S3140).
Hast du schon versucht deine IP vom Server auf den gängigen Blocklisten zu suchen?

Weiß nicht, ob du den MXToolbox Blacklist Check kennst. Aber eigentlich steht das ja in der Fehlermeldung. War bei mir vorher auch, dass die gemietete IP Adresse in einer Blacklist gestanden hat. War allerdings nur eine von ungefähr ~90 Listen. War aber einfach die IP Adresse wieder aus der Liste zu entfernen.

Nachtrag:

Da du einen DMARC Eintrag in deiner Domain hast, nehme ich auch mal an das du einen DKIM erstellt hast und die Mails signiert werden. Den will jedenfalls Google Mail bzw. deren Spam Filter.

Nachtrag Nummer 2:

Die Fehlermeldung kommt ja direkt vom Outlook SMTP Server... Kommt also gar nicht erst bis zu Spam Filter..
Der SPF Record sollte in Ordnung sein Kannst aber auch bei MXToolbox verifizieren. Wobei der IPv4 Eintrag nicht wirklich IMHO nötig ist. Da du sowieso alle MX'es das senden erlaubst.
 
Zuletzt bearbeitet:

overflow

Member of Honour
Die Mail kommt bei den meisten Anbietern wie Gmail, web.de etc an.

Lediglich bei Microsoft (Hotmail, Live, Outlook und Konsorten) gibt es Probleme. Bei T-Online hatte ich zu Beginn auch Probleme. Musste meine IP freigegeben lassen...
 
Oben