Nokogiri 1.5.10 unter Ubuntu 12.04

Ich versuche momentan ein Redmine 2.3 auf einer Ubuntu 12.04 VM mit Apache2 und Ruby 2.0 ans Laufen zu bringen. Beim "Bundlen" (# bundle install) bekomme ich folgende Fehlermeldung:

Code:
Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension.
    /usr/bin/ruby2.0 extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

Gem files will remain installed in /var/lib/gems/2.0.0/gems/nokogiri-1.5.10 for inspection.
Results logged to /var/lib/gems/2.0.0/gems/nokogiri-1.5.10/ext/nokogiri/gem_make.out

An error occurred while installing nokogiri (1.5.10), and Bundler cannot continue.
Make sure that `gem install nokogiri -v '1.5.10'` succeeds before bundling.

Inhalt von gem_make.out ist folgender:
Code:
/usr/bin/ruby2.0 extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

wenn ich es mit "# gem install nokogiri -v '1.5.10' " versuche, sehe ich folgenden Output:
Code:
Building native extensions.   This could  take a while...
ERROR:  Error installing nokogiri:
               ERROR: Failed to build gem native extension.

     /usr/bin/ruby2.0 extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h


Gem files will remain installed in /var/lib/gems/2.0.0/gems/nokogiri-1.5.10 for inspection.
Results logged to /var/lib/gems/2.0.0/gems/nokogiri-1.5.10/ext/nokogiri/gem_make.out

Output siehe oben. Ich habe mich bei Google umgesehen, aber keine funktionierende Lösung gefunden, bevor die Ergebnisse völlig ab vom Thema waren.
 
Erstmal vielen Dank für die Hilfe! :) Habe etwas graben müssen, bis ich durch Ausprobieren herausgefunden habe, dass ich es mit "apt-get install ruby2.0-dev" statt mir "ruby-dev" versuchen muss, aber jetzt hat es soweit funktioniert. Habe jetzt ein Problem mit mysql2, muss mich damit aber erst einmal weiter befassen.
 
Sämtliche Probleme haben sich durch das Installieren von x-dev libraries lösen lassen :) Bei mir sind Probleme nur noch bei
mysql2
Lösung:
Code:
sudo apt-get install libmysqlclient-dev
sudo gem install mysql2 -- --with-mysql-dir=/etc/mysql/

und rmagick
Lösung:
Code:
sudo apt-get install libmagickwand-dev

aufgetreten.
 
Zuletzt bearbeitet:
Oben