Vollständiges Entfernen jeglicher Rückstände einer missglückten Installation

Ich gehe etwas ins Detail um sicher zu gehen, dass alles relevante auftaucht:
Ich habe vor einiger Zeit versucht, das Spiel "Mirror's Edge" auf meinem neuen PC zu installieren. Da es allerdings schon auf meinem vorherigen Computer installiert war, konnte ich das Spiel im Nachhinein nicht ausführen. Das wusste ich zu besagtem Zeitpunkt nur noch nicht und habe deshalb versucht, das Spiel von meiner Partition für Spiele manuell nach C:/Programme zu kopieren. Als es dann immer noch nicht geklappt hat, bin ich endlich auf den Trichter gekommen, dass es daran liegt, dass ich das Spiel schon auf einem anderen PC installiert hatte. Gestern habe ich mir dann eine neue Lizenz für das Spiel gekauft und wollte es installieren. Dummerweise hat sich in der Zwischenzeit folgendes geändert: Meine Partition für Spiele ist mit Truecrypt verschlüsselt worden und ich habe das Spiel, da es sich nicht mehr auf "normalem" weg deinstallieren ließ, von Hand aus dem entsprechenden Verzeichnis entfernt. Als ich es dann erneut installieren wollte, stellte ich fest, dass mein wundervolles Windows immer noch "Mirror's Edge" ohne Icon in der Softwareliste führt und auch eine gezielte Ausführung des Setups auf der CD nur zu einer Fehlermeldung à "Der Pfad enthält die folgenden Zeichen und ist daher ungültig: <diverse Standard-Tabu-Zeichen für Verzeichnisangaben>" und der Beendung des Setups führt. Die Frage ist: Könnte ich das entsprechende .msi-Paket aus dem Installer Verzeichnis von Windows löschen und das Setup würde wie gewoht von vorne anfangen oder mache ich damit nur noch mehr böses fuu? Ansonsten bitte ich um andernweitige Hilfe^^
 

Brabax

New member
Schau mal, welche Daten noch an folgenden Orten liegen:

Registry:
HKEY_CURRENT_USER
HKEY_LOCAL_MACHINE
(wow86 nicht vergessen)

File-System:
C:\benutzer\NAME\appdata\...
C:\program files\
C:\program files (x86)\...
 
Ich habe jetzt aus allen genannten Verzeichnissen das, was noch da war gelöscht und auch das .msi-Paket im Installer-Verzeichnis gelöscht, aber es scheint immer noch irgendwo eine config o.ä. zu geben, in die ein ungültiger Installationspfad gespeichert ist.
 

Brabax

New member
google mal nach InstallWatcher, es gibt Tools, die überwachen, was bei einer Installation alles gemacht wird.
Dann installierst du mal auf einem sauberen System und überwachst die Installation.
Vielleicht kommst du damit weiter.

lG
 
Oben