Win 2k Server installieren?!

Machine

Member
Hi Leute,

also folgendes: ich hatte vor mir nen kleinen eigenen Server aufzusetzen. Zum mal austesten und dass man sagen kann, man hats schonmal gemacht ;)

Jetzt hab ich hier ne Win2k Server CD und habe ganz normal angefangen das aufzusetzen.
Funzt soweit auch, von CD booten, HDD formatieren, Dateien werden kopiert, bla.

Neustart, Rechner bootet von HDD. Das eigentliche Setup beginnt. Maus, Tastatiur, Zeugs wird gesucht und gefunden. Ich muss verschiedene Einstellungen vornehmen. Mach ich, funzt alles.

So, und nun will er neustarten. Macht er auch. Und dann? Von HDD booten, funzt. Aber dann geht das Setup wieder von vorn los, also bei Maus, Tastatur, usw suchen. Dann müsste ich alle Einstellungen nochmal machen. Und das immer und immer wieder. Ich hab alles 4 mal gemacht jetzt.. Ich weiß nichtmehr weiter. Kann mir da jemand helfen? Mach ich was falsch?

Gruß,
Machine
 

Ryloth

New member
puh,
ich habe schon dutzende W2K Server aufgesetzt und diesen Effekt hatte ich noch nie!

Ne blöde Frage, kann es sein das du beim Neustarten ne Taste drückst und das er deswegen den installationsassitenten erneut durchlaufen lässt?

Bist du sicher das die HDD Ok ist, bzw. der richtige Controller bei der Installation ausgewählt wurde?
Beim starten mit F6 kannst du den angeben.

Da er die HDD aber erkennt glaube ich selber nicht das es daran liegen kann.
 

Machine

Member
Erstmal danke für die Antwort.

Also es ist so: ich wollte das zum Testen erstmal in ner VM machen und nutze VirtualBox.
Ich drücke auch definitiv keine Taste, er bootet beim Neustart auch von der Platte. Also denke ich, sie ist auch in Ordnung, was bei ner VM-Platte auch so sein sollte ;)

Mir scheint es, als würde er die Einstellungen, die ich in dem Assistenten vornehme nicht speichert, oder so...
 

beavisbee

Member of Honour
Original von M4CH!N3
Mir scheint es, als würde er die Einstellungen, die ich in dem Assistenten vornehme nicht speichert, oder so...
klingt bald so....

hast du mal noch irgend eine alte Festplatte da, wo du die Installation mal auf ner richtigen Platte versuchen kannst anstatt auf ner VMWare?

ansonsten bleibt nur die Alternative, dass du ein alternatives Server-Betriebssystem nutzt :D
(ich denke da so an ein Gnu und einen Pinguin... ;) )
 

Machine

Member
Ja, am Wochenende könnte ich es auf nem richtigen Rechner testen.. mal schauen, dann werde ich das mal tun.

Die Sache mit dem Pinguin ist irgenwie nichts für mich, ich komm einfach nicht so wirklich an Linux ran ;)
 

hamill

New member
dann nimm BSD. DfBSD 2.0 ist gerade diese Woche neu im Angebot!

(übrigens, Windows 2000 kann man meines Wissen aktuell nicht mehr käuflich erwerben, selbst wenn man will)
 

-=Draven=-

Member of Honour
Der Fehler ist in dern Anleitung von Virtualbox beschrieben. Schau mal bei
Problemen mit Windows 2000 Installationen. Hatte das selbe Problem aber sowohl im Virtualbox Forum als auch in der Hilfe findet man die Lösung...
 

-=Draven=-

Member of Honour
11.2.2 Windows 2000 installation failures
When installing Windows 2000 guests, you might run into one of the following
issues:
? Installation reboots, usually during component registration.
? Installation fills the whole hard disk with empty log files.
? Installation complains about a failure installing msgina.dll.
These problems are all caused by a bug in the hard disk driver of Windows 2000.
After issuing a hard disk request, there is a race condition in the Windows driver
code which leads to corruption if the operation completes too fast, i.e. the
hardware interrupt from the IDE controller arrives too soon. With physical
hardware, there is a guaranteed delay in most systems so the problem is usually
hidden there (however it should be possible to reproduce it on physical hardware
as well). In a virtual environment, it is possible for the operation to be done
immediately (especially on very fast systems with multiple CPUs) and the interrupt
is signaled sooner than on a physical system. The solution is to introduce an
artificial delay before delivering such interrupts.
This delay can be configured for a VM using the following command:

VBoxManage setextradata <vmname>
"VBoxInternal/Devices/piix3ide/0/Config/IRQDelay" 1

This sets the delay to one millisecond. In case this doesn?t help, increase it to a
value between 1 and 5 milliseconds. Please note that this slows down disk
performance.
After installation, you should be able to remove the key (or set it to 0).


Bei Windows 2000 liegt es an dem Fehler und das sollte genau das selbe sein wie
dein Problem.
 

Machine

Member
hm, das hab ich ja schon versucht.. da bekommt ich n haufen fehlermeldungen und das wars..
ich hab aber ne aktuellere VB-version gefunden.. ich zieh mir das mal und versuchs damit nochmal.

EDIT: mit der aktuellsten Version von VirtualBox funzt die von -=Draven=- genannte Lösung auch. Vielen Dank an alle, Thread closed.
 
Oben