WLAN interface lässt sich nicht in moitor mode schalten

sonny

New member
Hallo ich versuche grade meine WLAN interface in den monitor mode
zu schalten, was nicht funktioniert. Hat da jemand einen Tip?


Code:
i ~ $ sudo airmon-ng start wlpls0


Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID    Name
921    avahi-daemon
941    NetworkManager
1020    avahi-daemon
1127    wpa_supplicant
4783    dhclient
Process with PID 4783 (dhclient) is running on interface wlp1s0


Interface    Chipset        Driver

wlp1s0        Broadcom    wl - [phy0]

iago@iago-TravelMate-8172 ~ $
iwconfig zeigt, dass es nicht funktioniert hat:

Code:
iwconfig
enp3s0    no wireless extensions.

lo        no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"oeserstr_103"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 5C:49:79:28:02:DD   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
wwp0s26u1u6i6  no wireless extensions.
Vielen Dank!
 

sonny

New member
Hi,
hab ich versucht mit:
Code:
airmon-ng check kill
Zum einen klappt das mit dem Umschalten auf monitor mode dann auch nicht,
zum anderen schalt ich dann auch den Netzwerkmanager ab, ob das hilfreich ist?

Selsamerweise lassen sich die avahi-daemons auch nicht killen sondern
öffnen unter einener anderen PID.
 
Zuletzt bearbeitet:

@night@

Stammuser
Also bei mir hats früher immer mit den meist schon vorinstallierten Werkzeugen geklappt:
ich@hier:~$ sudo ifconfig wlan0 down
ich@hier:~$ sudo iwconfig wlan0 mode monitor
ich@hier:~$ sudo ifconfig wlan0 up
ich@hier:~$ iwconfig
wlan0 IEEE 802.11 Mode:Monitor Tx-Power=22 dBm
Retry short limit:7 RTS thr:eek:ff Fragment thr:eek:ff
Power Management:eek:n

enp4s0 no wireless extensions.

lo no wireless extensions.
sieher auch hier.

Wenn der Modus nach einiger Zeit automatisch wieder zu Managed wechselt, musst du zuerst deine Verbindung zum momentanen AP trennen und auch verhindern, dass der Netzwerktreiber sich wieder automatisch beim Netzwerk anmeldet (->Drahtloseinstellungen).

Grüße
 

xeno

Moderator
Mitarbeiter
Ich persönlich würde bei solchen Sachen den NM komplett abschalten. Weiß der Geier, was der im Hintergrund alles wieder umstellt. Außerdem lernt man so ganz gut, wie man seine Drahtlosverbindung manuell einrichtet. ;)
 

sonny

New member
Mit der externen Karte (reltek) funzt es, wahrscheinlich muss ich jetzt nur die interne abschalten,
oder die Verbindung komplett manuell aufbauen, wie gesagt wurde!?

Code:
Interface    Chipset        Driver

wlx74da38e2f0fa        Unknown     rtl8192cu - [phy3]
                (monitor mode enabled on mon0)

wlp1s0        Broadcom    wl - [phy0]
iwconfig ergibt nun:

Code:
mon0      IEEE 802.11  Mode:Monitor  Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on
          
wlx74da38e2f0fa  IEEE 802.11  ESSID:"mycloud"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: F0:B0:52:1C:23:98   
          Bit Rate=72.2 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:off
          Link Quality=54/70  Signal level=-56 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:2   Missed beacon:0

wwp0s26u1u6i6  no wireless extensions.

enp3s0    no wireless extensions.

wlp1s0    IEEE 802.11  ESSID:"mycloud"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: F0:B0:52:1C:23:98   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          
lo        no wireless extensions.
Der reltek-chip ist nun, so wie ich das vertehe, in 2 versch. Modi aktiv.
 
Oben